Check Engine Light - Nissan Titan XD Forum
 5Likes
Reply
 
Thread Tools
post #1 of 13 Old 02-23-2017, 08:54 AM Thread Starter
Senior Member
 
Bikerndiver's Avatar
 
Join Date: Oct 2015
Location: NC
Posts: 401
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 100 Post(s)
Garage
(Thread Starter)
Check Engine Light

So, I left NC for a trip to Miami and back to see some relatives and check out our land in Georgia..... I got as far as Daytona Beach and a check engine light came on. All gauges were fine, truck continued to run good.... Went to Daytona Nissan and waited 2 hours for them to diagnose the issue. The diesel tech said there were "past codes" that were in the system that caused the check engine light to come on. Everything checked out as OK. He went through the procedure to remove the old codes and sent me on my way. Just about 145 miles later...the check engine light came back on. Again, engine was running fine, instruments were all in the normal range.
This time, I kept on driving all the way to Miami and back to NC.
This morning I dropped the truck off at my local dealership and they gave me a loaner to get to work. Hopefully, they can find out what is causing the CEL and shut it off. At least on this trip it wasn't a DEF system failure like the last time. I still love my truck, but I hate these little annoyances.

Since I had such a long ride and had some open road, I experimented with some driving speed and mpg. I had my fully loaded, slide in truck camper on, and at 73 mph, I was getting 14.5 mpg. At 63 I got 16.7 mpg.
Bikerndiver is online now  
Sponsored Links
Advertisement
 
post #2 of 13 Old 02-23-2017, 10:15 AM
Junior Member
 
Join Date: Aug 2016
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Garage
Just dropped mine off for the same thing this morning. have had the def warning as well in the past. starting to get tired of all the problems I keep having out of it. long time(2005) titan owner!! love the trucks, but thinking I bought a lemon this time. So far been in the shop around 26 days total in 7 months.
BlackTitanXD is online now  
post #3 of 13 Old 02-23-2017, 10:29 AM
Senior Member
 
Join Date: Oct 2015
Posts: 1,338
Mentioned: 4 Post(s)
Tagged: 1 Thread(s)
Quoted: 371 Post(s)
Quote:
Originally Posted by BlackTitanXD View Post
Just dropped mine off for the same thing this morning. have had the def warning as well in the past. starting to get tired of all the problems I keep having out of it. long time(2005) titan owner!! love the trucks, but thinking I bought a lemon this time. So far been in the shop around 26 days total in 7 months.
Not a lemon, just a modern Diesel. It's either you get one that's completely trouble free or you get......
I'm not dogging Diesels but I've said for several years now, if you don't really need a Diesel ( really no reason with a XD ) don't buy one.
Hope they get you fixed up!!

2016 Black XD Pro4x.....
AZPRO4X is offline  
 
post #4 of 13 Old 02-23-2017, 10:49 AM
Junior Member
 
Join Date: Aug 2016
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Garage
Quote:
Originally Posted by AZPRO4X View Post
Not a lemon, just a modern Diesel. It's either you get one that's completely trouble free or you get......
I'm not dogging Diesels but I've said for several years now, if you don't really need a Diesel ( really no reason with a XD ) don't buy one.
Hope they get you fixed up!!
I do understand what you are saying. I also know of new model bugs. I am just getting tired of taking my 55k truck to the dealership every month (or twice) based on problems. I only have 10k miles on it. I hope mine is just a lemon, and this in not happening to everyone, and I hope they do fix it, where this stops. I hate that the service guys know me by first name. Again, I do lover truck!! Just want it reliable. Hope yours get fixed as well, and no further problems.
Louisiana Pro4X likes this.
BlackTitanXD is online now  
post #5 of 13 Old 02-23-2017, 11:14 AM
Senior Member
 
Join Date: Oct 2015
Posts: 1,338
Mentioned: 4 Post(s)
Tagged: 1 Thread(s)
Quoted: 371 Post(s)
Quote:
Originally Posted by BlackTitanXD View Post
I do understand what you are saying. I also know of new model bugs. I am just getting tired of taking my 55k truck to the dealership every month (or twice) based on problems. I only have 10k miles on it. I hope mine is just a lemon, and this in not happening to everyone, and I hope they do fix it, where this stops. I hate that the service guys know me by first name. Again, I do lover truck!! Just want it reliable. Hope yours get fixed as well, and no further problems.
Yeah, I get it. My 08 Titan spent it's 1st few months in & out of the shop for a weird vibration, $10k later worth of warranty charges it turned out the rear driveshaft just needed to be turned 1 notch to the left ( Clocked ). Frustrating to say the least.

2016 Black XD Pro4x.....
AZPRO4X is offline  
post #6 of 13 Old 02-23-2017, 11:14 AM
Member
 
Join Date: Jan 2016
Posts: 91
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 32 Post(s)
Quote:
Originally Posted by BlackTitanXD View Post
Quote:
Originally Posted by AZPRO4X View Post
Not a lemon, just a modern Diesel. It's either you get one that's completely trouble free or you get......
I'm not dogging Diesels but I've said for several years now, if you don't really need a Diesel ( really no reason with a XD ) don't buy one.
Hope they get you fixed up!!
I do understand what you are saying. I also know of new model bugs. I am just getting tired of taking my 55k truck to the dealership every month (or twice) based on problems. I only have 10k miles on it. I hope mine is just a lemon, and this in not happening to everyone, and I hope they do fix it, where this stops. I hate that the service guys know me by first name. Again, I do lover truck!! Just want it reliable. Hope yours get fixed as well, and no further problems.
One of the guys I get contract work from bought a duramax that was doing the same ****. In the shop every month for like 2 yrs. They sorted it out.. truck is an effin beast and hasnt been back in the dealer for quite a long time.

Im sure yours will get sorted out too!
BlackTitanXD likes this.
jd96 is offline  
post #7 of 13 Old 02-23-2017, 11:35 AM
Member
 
Join Date: Oct 2016
Location: Alberta
Posts: 88
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Yeah mine came on last week drove fine. Brought it in yesterday see what issue is this time. I get your frustration with all these little things it drives me absolutely nuts as well. But on the bright side they gave me a brand new full load Murano to drive around for a few days.


Sent from my iPhone using Tapatalk
BlackTitanXD likes this.
Bertatitan is offline  
post #8 of 13 Old 02-23-2017, 12:16 PM
Guest
 
Join Date: Jan 2017
Posts: 113
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 45 Post(s)
Question What loaner did the dealer give ya?

Quote:
Originally Posted by Bikerndiver View Post
So, I left NC for a trip to Miami and back to see some relatives and check out our land in Georgia..... I got as far as Daytona Beach and a check engine light came on. All gauges were fine, truck continued to run good.... Went to Daytona Nissan and waited 2 hours for them to diagnose the issue. The diesel tech said there were "past codes" that were in the system that caused the check engine light to come on. Everything checked out as OK. He went through the procedure to remove the old codes and sent me on my way. Just about 145 miles later...the check engine light came back on. Again, engine was running fine, instruments were all in the normal range.
This time, I kept on driving all the way to Miami and back to NC.
This morning I dropped the truck off at my local dealership and they gave me a loaner to get to work. Hopefully, they can find out what is causing the CEL and shut it off. At least on this trip it wasn't a DEF system failure like the last time. I still love my truck, but I hate these little annoyances.

Since I had such a long ride and had some open road, I experimented with some driving speed and mpg. I had my fully loaded, slide in truck camper on, and at 73 mph, I was getting 14.5 mpg. At 63 I got 16.7 mpg.
Like the title says.
17106 is offline  
post #9 of 13 Old 02-23-2017, 01:08 PM Thread Starter
Senior Member
 
Bikerndiver's Avatar
 
Join Date: Oct 2015
Location: NC
Posts: 401
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 100 Post(s)
Garage
(Thread Starter)
Quote:
Originally Posted by 2016NissanTitanXDSDiesel View Post
Like the title says.
They gave me a Rogue to drive.... A little bit small compared to the XD, but got me to work.
17106 likes this.
Bikerndiver is online now  
post #10 of 13 Old 02-23-2017, 10:05 PM
Senior Member
 
Join Date: Aug 2016
Posts: 288
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 77 Post(s)
Quote:
Originally Posted by AZPRO4X View Post
Yeah, I get it. My 08 Titan spent it's 1st few months in & out of the shop for a weird vibration, $10k later worth of warranty charges it turned out the rear driveshaft just needed to be turned 1 notch to the left ( Clocked ). Frustrating to say the least.
The techs had their heads up their asses.
That should have been one of the first things they checked.
AZPRO4X likes this.
WVhillbilly is online now  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome