5.6l 7 speed transmission??? - Nissan Titan XD Forum
 8Likes
Reply
 
Thread Tools
post #1 of 48 Old 09-21-2016, 08:15 PM Thread Starter
Member
 
Join Date: Sep 2016
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
(Thread Starter)
5.6l 7 speed transmission???

I have a gas Pro4x with 700miles on it had 38 when I drove off the lot.

Just curious if any one else noticed when light ecelerating from a complete stop, transmission shifts 1, 2, maybe 3 then just goes flat rpms come down from 2500-3000 to 1500 and truck feels like it has a dead spot between 2nd 3rd or 3rd an 4th. I come from driving an FJ cruiser for 10 years and didn't seem to have any hesitation in any gear. Now I did also noticed hard ecelerating from a stop it doesn't to it as bad but there is still a slight lag after 1st an 2nd can't tell if it does it 3rd or 4th.

Hopefully the transmission learns itself to my driving and I don't have a potential probably down the road. I seemed to be babying the truck little more than hard driving but. This transmission isn't new and the only thing I come across was an article some where saying that they just retuned it for the XD

Thanks for reading and welcome any responses. By the way instill absolutely love my truck. And have owned Nissan vehicles in the past and Infiniti. Not new to nissan.

Sent from my XT1254 using Tapatalk
TitanCowboy likes this.
Mrhairlessmerkin is online now  
Sponsored Links
Advertisement
 
post #2 of 48 Old 09-21-2016, 10:21 PM
Senior Member
 
Join Date: Oct 2015
Posts: 1,184
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 327 Post(s)
The tranny needs to learn your driving style & you will get used to its qwerks. So give it some time to see if it adjusts. The Dodge guys have been dealing with the Trans for several years now & they complained about the same shifting weirdness but it seems to clear up.
AZPRO4X is offline  
post #3 of 48 Old 09-21-2016, 10:28 PM Thread Starter
Member
 
Join Date: Sep 2016
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
(Thread Starter)
I had figured that was the case and we will see after a few thousand miles. Thanks

Sent from my XT1254 using Tapatalk
Mrhairlessmerkin is online now  
post #4 of 48 Old 09-21-2016, 10:31 PM
Member
 
Join Date: Apr 2016
Location: Alberta Canada
Posts: 70
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Garage
he has the gas with the 7 speed AZPRO.. not the Dodge one.. but yes you are right about the learning curve.. mine took about 3000 miles to get smart.. but every once and a while it shifts a little too quick to the next gear

04 le, 08 pro4x, 09 pro4x, 12 sl.. 2016 XD SL Gas Gun Metal
TitanCowboy is offline  
post #5 of 48 Old 09-21-2016, 10:37 PM
Senior Member
 
dragon4x4's Avatar
 
Join Date: Jan 2016
Location: Edmonton, Alberta
Posts: 789
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 210 Post(s)
Garage
Get your foot into it and see what it does.
Go into manual mode and slowly bring up the rpm and manually shift it, see what it does.

My tranny was good and than all of a sudden @ 14000km, I had a some funky shifts between 1 and 2, it would shift at 1700rpm with my foot hard down and than it would stumble than shift. Went to the dealer and they reflashed the trans and now it seems to be good. Shifts at 2200-2400 now so it's a lot better.
dragon4x4 is online now  
post #6 of 48 Old 09-22-2016, 07:46 AM
Banned
 
Join Date: Mar 2015
Posts: 420
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 200 Post(s)
Most automatics shift pretty weak. After a tune, my 5.0 with the 6r80 was a completely different truck. It was not the whopping 9 hp that made a difference for the gasser, but the new shift strategy. It Nissan has the solution instead of shelling out for an aftermarket one, all the better.
nihilus is online now  
post #7 of 48 Old 09-25-2016, 12:10 AM Thread Starter
Member
 
Join Date: Sep 2016
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
(Thread Starter)
After putting my foot into it it is a little better but it is still there. Normal driving conditions. I can replicate it every time. I will have to bring the truck in for my alignment it pulls to the right so I will at the very least show this to them not sure what they could do. It doesn't feel normal. I am a mechanic/machinist by trade and have worked on my fair share of all the of vehicles. This to me should happen. I will be waiting till I hit about 2k miles if nothing. Changes its going in.

Sent from my XT1254 using Tapatalk
Mrhairlessmerkin is online now  
post #8 of 48 Old 11-20-2016, 07:28 PM
Member
 
Join Date: Sep 2016
Posts: 38
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
I'm curious if anyone with the Gasser, 7spd in the 1/2ton Titan is having this problem, like my wife is in her '17 Armada:

light throttle at speed (40-50mph, 1200-1500rpm)
transmission seems to be in 7th... Trying to accelerate slightly, and it feels like it thumps from 6-7-6-7-6-7. You can hear and feel it.

Going to try and take it to dealer tomorrow... Only 2300mi on it.
fifthcir is online now  
post #9 of 48 Old 11-21-2016, 05:33 AM
Banned
 
Join Date: Mar 2015
Posts: 420
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 200 Post(s)
@fifthcir - My Cx-9 used to thump between 5th and 6th at 40 MPH. The dealer said it was what they were suppose to do, which was kind of annoying.

There are some XD owners here that complain of how there 7-speed doesn't shift into 5th until 40 mph (1900 rpm or so) where as your Armada tries to shift into 7th at 40 mph (1200 rpm).

Seems they have some bugs to work out on the 7-speed. Who knows if there will be a fix for it.
nihilus is online now  
post #10 of 48 Old 11-21-2016, 06:44 PM
Member
 
Join Date: May 2016
Posts: 55
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Yes mine and others do the same thing. It really only happens under light throttle, say when stuck in traffic and can only go as fast as the traffic accelerates. It is very annoying and I hope Nissan comes out with a flash to address it.

Don't count on it "learning" its way out of it. 7k miles later mine still does it, if anything its worse.

Manually shifting takes care of it. Recently when in city traffic I just put it in 3rd so it won't go to 4TH until I manually shift it or it hits redline
scotts954 is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome