and the problems keep coming... - Nissan Titan XD Forum
 15Likes
Reply
 
Thread Tools
post #1 of 42 Old 01-10-2017, 05:03 PM Thread Starter
Junior Member
 
Join Date: Oct 2016
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
(Thread Starter)
and the problems keep coming...

First the turbo recall and downtime for that, then the breather tube recall and downtime for that...now my XD has to go back in the shop for an instrument panel replacement! The "range to empty" indicator, the number that tells you how many miles you have left on the tank of fuel, is stuck on 170. After filling the tank, the indicator always resets to show the current range on a full tank. This time it stayed at 170. It was filled with the truck off / key off. Ran the truck for half hour, then another 10 miles that afternoon and still stuck. It sat overnight, checked...still at 170. The first rocket scientist service writer I talked to said it could take up to 2 days to reset...BS, it used to do it immediately. I called back when the "good" service writer was in, he told me the instrument cluster needs to be replaced. He said he's seen 4 other cases of it, and there is a defect in the panel. The only solution is a replacement. Unbelievable, while I am glad Nissan is standing behind the truck...all these issues have me seriously considering jumping ship.
Poochie1 is offline  
Sponsored Links
Advertisement
 
post #2 of 42 Old 01-10-2017, 07:53 PM
Senior Member
 
Join Date: Sep 2016
Posts: 365
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 105 Post(s)
I guess I should check mine, I don't think I've ever looked at the "range to empty".
Demiles is online now  
post #3 of 42 Old 01-11-2017, 09:19 PM
Member
 
Phantom XD's Avatar
 
Join Date: Dec 2016
Location: VA
Posts: 80
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 42 Post(s)
Quote:
Originally Posted by Poochie1 View Post
First the turbo recall and downtime for that, then the breather tube recall and downtime for that...now my XD has to go back in the shop for an instrument panel replacement! The "range to empty" indicator, the number that tells you how many miles you have left on the tank of fuel, is stuck on 170. After filling the tank, the indicator always resets to show the current range on a full tank. This time it stayed at 170. It was filled with the truck off / key off. Ran the truck for half hour, then another 10 miles that afternoon and still stuck. It sat overnight, checked...still at 170. The first rocket scientist service writer I talked to said it could take up to 2 days to reset...BS, it used to do it immediately. I called back when the "good" service writer was in, he told me the instrument cluster needs to be replaced. He said he's seen 4 other cases of it, and there is a defect in the panel. The only solution is a replacement. Unbelievable, while I am glad Nissan is standing behind the truck...all these issues have me seriously considering jumping ship.
Just curious, what build date do you have and how many miles on it?
Phantom XD is offline  
 
post #4 of 42 Old 01-16-2017, 04:47 PM Thread Starter
Junior Member
 
Join Date: Oct 2016
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
(Thread Starter)
build date is 03/2016. I finally adjusted my schedule so that I can bring the truck in today for the service. Can't wait to see what this adventure brings. Also, today while driving to the dealership the truck killed twice. Going straight, ran perfect...absolute dream. While making a turn, either left or right and giving it fuel, the truck stalled right in the middle of the intersection. Granted, it started right back up...but WTH, I can't make turns with it now? I'll update with the results of what they find and do with the instrument panel.
Poochie1 is offline  
post #5 of 42 Old 01-16-2017, 04:56 PM
Member
 
Join Date: Nov 2016
Location: Bartlett, TN
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Ugh. I like my truck but all these problems are making me nervous. I already lost money when I traded my car in to get this truck. I'm not in position to lose money again to get out of a troublesome truck. Two trips to the dealer for issues in less than two months. Hope that's not an average...

Hope your issues get corrected.
60bubba is offline  
post #6 of 42 Old 01-19-2017, 09:04 AM Thread Starter
Junior Member
 
Join Date: Oct 2016
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
(Thread Starter)
got the truck back from the dealer last night..."official" response from Nissan: "I don't drive my truck hard enough." Luckily, before the tech cracked open my dashboard to change the cluster he called the master tech phone line or something. He was advised that they've seen numerous Titan XD's come in for the same problem, and the issue is from the truck sitting longer than it's being run and not being able to go into regeneration. Granted, my truck sits for most of the week...the occasional trip down the highway to the store or to pick up my kid. On the weekends I use it to pull my Jeep on a trailer to different off-road parks. Most of the time the weekend trips are an hour and a half away, but sometimes up to 3.5 hours. You'd figure that would be enough to put it into regeneration when needed, but evidently not. I was told that running it like I do on the weekends is great, but the sitting for the week after is killing it and allowing the filter to become clogged and the truck can't do what's it supposed to do. The solution was to put it through a manual regeneration using their scan tool. Everything is working now as it should, all the gauges are back to normal and I drove it today for my 1.5 hour commute to work and experienced no problems with the truck killing or stalling. LOL, the service manager asked me to please be patient with them, they are all learning the ins and outs of the XD...I still can't ask for better service than I've received from Nissan. They really are standing behind this truck. My only issue is that I've had the other brands, and have used them the same way, and never had problems with the trucks going into regeneration. I asked if putting it through a manual regeneration is something I can do at home if this happens again, they said NO, it had to be done with their scan tool. So, we'll wait to see what happens...until then, my commute was incredible this morning compared to driving my beater work truck, as this XD truly is the best truck I've ever driven.
Poochie1 is offline  
post #7 of 42 Old 01-19-2017, 11:11 AM
Senior Member
 
slurpee3's Avatar
 
Join Date: Nov 2016
Location: Round Rock, TX
Posts: 639
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 224 Post(s)
Garage
Quote:
Originally Posted by Poochie1 View Post
got the truck back from the dealer last night..."official" response from Nissan: "I don't drive my truck hard enough." Luckily, before the tech cracked open my dashboard to change the cluster he called the master tech phone line or something. He was advised that they've seen numerous Titan XD's come in for the same problem, and the issue is from the truck sitting longer than it's being run and not being able to go into regeneration. Granted, my truck sits for most of the week...the occasional trip down the highway to the store or to pick up my kid. On the weekends I use it to pull my Jeep on a trailer to different off-road parks. Most of the time the weekend trips are an hour and a half away, but sometimes up to 3.5 hours. You'd figure that would be enough to put it into regeneration when needed, but evidently not. I was told that running it like I do on the weekends is great, but the sitting for the week after is killing it and allowing the filter to become clogged and the truck can't do what's it supposed to do. The solution was to put it through a manual regeneration using their scan tool. Everything is working now as it should, all the gauges are back to normal and I drove it today for my 1.5 hour commute to work and experienced no problems with the truck killing or stalling. LOL, the service manager asked me to please be patient with them, they are all learning the ins and outs of the XD...I still can't ask for better service than I've received from Nissan. They really are standing behind this truck. My only issue is that I've had the other brands, and have used them the same way, and never had problems with the trucks going into regeneration. I asked if putting it through a manual regeneration is something I can do at home if this happens again, they said NO, it had to be done with their scan tool. So, we'll wait to see what happens...until then, my commute was incredible this morning compared to driving my beater work truck, as this XD truly is the best truck I've ever driven.
The reasoning from your dealership behind all of this doesn't make sense to me. I agree, the time you stated you spend on the road is plenty for the vehicle to do its thing and letting it sit afterwards should not be causing the issues you've stated. I say something is up, but what do I know.

2016 Titan XD PR 4x4, bone stock
slurpee3 is online now  
post #8 of 42 Old 01-19-2017, 11:17 AM
Banned
 
Join Date: Jun 2016
Location: Republic of Texas
Posts: 369
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 194 Post(s)
And problems will continue to come...

Quote:
Originally Posted by Poochie1 View Post
First the turbo recall and downtime for that, then the breather tube recall and downtime for that...now my XD has to go back in the shop for an instrument panel replacement! The "range to empty" indicator, the number that tells you how many miles you have left on the tank of fuel, is stuck on 170. After filling the tank, the indicator always resets to show the current range on a full tank. This time it stayed at 170. It was filled with the truck off / key off. Ran the truck for half hour, then another 10 miles that afternoon and still stuck. It sat overnight, checked...still at 170. The first rocket scientist service writer I talked to said it could take up to 2 days to reset...BS, it used to do it immediately. I called back when the "good" service writer was in, he told me the instrument cluster needs to be replaced. He said he's seen 4 other cases of it, and there is a defect in the panel. The only solution is a replacement. Unbelievable, while I am glad Nissan is standing behind the truck...all these issues have me seriously considering jumping ship.
I'm really disappointed with Nissan on XDs. How could they screw up like this? Do they know that the competition is unforgiving? Nissan, if you're listening, get your act together and start fixing this mess!
TexasPRO4X is offline  
post #9 of 42 Old 01-19-2017, 11:22 AM
Senior Member
 
Bikerndiver's Avatar
 
Join Date: Oct 2015
Location: NC
Posts: 581
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 141 Post(s)
Garage
Quote:
Originally Posted by Poochie1 View Post
got the truck back from the dealer last night..."official" response from Nissan: "I don't drive my truck hard enough." Luckily, before the tech cracked open my dashboard to change the cluster he called the master tech phone line or something. He was advised that they've seen numerous Titan XD's come in for the same problem, and the issue is from the truck sitting longer than it's being run and not being able to go into regeneration. Granted, my truck sits for most of the week...the occasional trip down the highway to the store or to pick up my kid. On the weekends I use it to pull my Jeep on a trailer to different off-road parks. Most of the time the weekend trips are an hour and a half away, but sometimes up to 3.5 hours. You'd figure that would be enough to put it into regeneration when needed, but evidently not. I was told that running it like I do on the weekends is great, but the sitting for the week after is killing it and allowing the filter to become clogged and the truck can't do what's it supposed to do. The solution was to put it through a manual regeneration using their scan tool. Everything is working now as it should, all the gauges are back to normal and I drove it today for my 1.5 hour commute to work and experienced no problems with the truck killing or stalling. LOL, the service manager asked me to please be patient with them, they are all learning the ins and outs of the XD...I still can't ask for better service than I've received from Nissan. They really are standing behind this truck. My only issue is that I've had the other brands, and have used them the same way, and never had problems with the trucks going into regeneration. I asked if putting it through a manual regeneration is something I can do at home if this happens again, they said NO, it had to be done with their scan tool. So, we'll wait to see what happens...until then, my commute was incredible this morning compared to driving my beater work truck, as this XD truly is the best truck I've ever driven.
Sounds like another reason for a full delete kit.... Although, mine doesn't sit that long, so I'm not apt to have that problem.
Bikerndiver is online now  
post #10 of 42 Old 01-19-2017, 11:27 AM
Senior Member
 
WYXD's Avatar
 
Join Date: Nov 2016
Location: Rock Springs, WY
Posts: 257
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Quote:
Originally Posted by Poochie1 View Post
Titan XD's come in for the same problem, and the issue is from the truck sitting longer than it's being run and not being able to go into regeneration. Granted, my truck sits for most of the week...the occasional trip down the highway to the store or to pick up my kid

Well, after reading this, I'm screwed. I've had my truck for 3 months and it only has 450 miles on it. I bought it to tow the camper and really can't do that now so other than a trip to Home Depot, it just sits in the garage. Driving it to work is a waste because that's a 4 minute drive and I'd rather drive the Jetta for that. So I'll be curious if it starts having issues.



Sent from my iPhone using Tapatalk

2016 PRO-4X Diesel
WYXD is online now  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome