CEL On, P226C Turbocharger Boost Control Slow Response - Nissan Titan XD Forum
 
Thread Tools
post #1 of 4 Old 07-01-2018, 08:37 PM Thread Starter
Senior Member
 
Join Date: Aug 2016
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 43 Post(s)
(Thread Starter)
CEL On, P226C Turbocharger Boost Control Slow Response

My check engine came on today while towing but no warning. Pulled the code and got a P226C.

P226C (Turbocharger Boost Control Slow Response)


Anybody else get this? What was the remediation?

I realize there is a TSB but not sure if it's related as I have recent firmware.

NTB16-095 2016 NISSAN TITAN XD; MIL ON WITH DTC P226C OR P0471
One or both of the following DTCs are stored:
P226C (Turbocharger Boost Control Slow Response)
P0471 (Exhaust Pressure Sensor "A" Circuit Range/Performance)
and
There are no drivability issues.
mstang1988 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-02-2018, 03:38 PM
Senior Member
 
bcangelo's Avatar
 
Join Date: Jul 2017
Location: San Angelo, TX
Posts: 186
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 43 Post(s)
Garage
I had this Saturday, it was at closing time so he cleared it for me. The truck would run fine up till 60 and then had no power, reminded me of my 2.3l ranger. The light came back on an hour later. Took it in first thing this morning, after about an hour I got a call that it was a vacuum hose on the turbo had come loose. I had the complete fuel system replaced this month due to Sam's mixing fuels.

2016 PR XD 4x4
5.0 Cummins
Java/Bone
bcangelo is online now  
post #3 of 4 Old 07-08-2018, 02:49 PM
Junior Member
 
Join Date: Jul 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Joined today for this issue, had ecm changed under warranty after some diag and same code is popping again....p226c. Anyone have any luck figuring out what’s wrong and how to fix?
MTR8TD is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old Today, 08:20 PM
Member
 
Ksalway's Avatar
 
Join Date: Dec 2018
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)
Got this code for the second time today, dealer said they can’t get me in until Monday. What was the fix for this issue?
Ksalway is online now  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome