Nissan Titan XD Forum banner

1 - 11 of 11 Posts

·
Registered User
Joined
·
9 Posts
Discussion Starter #1
My 17 Titan xd is hard to start in the morning hot or cold temps same thing after you get it started runs fine starts fine all day leave it over night same thing every morning
 

·
Registered User
Joined
·
594 Posts
Do you park on the drive way nose-up or nose-down? How much fuel in the tank when that happened?
 

·
Registered User
Joined
·
9 Posts
Discussion Starter #3
Do you park on the drive way nose-up or nose-down? How much fuel in the tank when that happened?
Full I usually park level I’ve narrowed it down I let my truck sit yesterday about 6 hrs and it did it it was 65 degrees outside so it s not a hot or cold issue it’s obviously loosing prime just don’t know where from
 

·
Registered User
Joined
·
143 Posts
Do you jump in and straight start it? Or do you press the button twice, wait about 5 seconds or so and then start? I found that helps with starting.

Stay frosty
 

·
Registered User
Joined
·
9 Posts
Discussion Starter #5
Do you jump in and straight start it? Or do you press the button twice, wait about 5 seconds or so and then start? IiI found that helps with starting.
I’ve tried don’t make no diff my lift pump never turn s off like they say it does after it primes I know it runs continuously while truck is running but they say it shuts off if it primes up mine never does
Stay frosty
 

·
Registered User
Joined
·
9 Posts
Discussion Starter #7
When’s the last time you changed fuel filters?
I changed them twice in a week to see if it was something wrong no luck I’m using what the local parts house sales I’m gonna try Nissan filters tomorrow but I don’t know if it will make a diff
 

·
Registered User
Joined
·
474 Posts
I changed them twice in a week to see if it was something wrong no luck I’m using what the local parts house sales I’m gonna try Nissan filters tomorrow but I don’t know if it will make a diff
Hmmm- that kinda rules that out. Probably a good idea for OEM filters just to rule that out.

Check your air filter to make sure it hasn’t sucked into the air intake tube- I read about a guy on here who that happened to and one of his many symptoms was a hard start.
 

·
Registered User
Joined
·
9 Posts
Discussion Starter #9
Hmmm- that kinda rules that out. Probably a good idea for OEM filters just to rule that out.

Check your air filter to make sure it hasn’t sucked into the air intake tube- I read about a guy on here who that happened to and one of his many symptoms was a hard start.
ok I’ll check it out
 

·
Registered User
Joined
·
275 Posts
Maybe check your battery terminals, too, if you haven't already - the stock batteries have a bad habit of corroding on the positive terminal - I've gotta clean mine every six months or so.
 
1 - 11 of 11 Posts
Top