Nissan Titan XD Forum banner
1 - 2 of 2 Posts

·
Registered User
2016 Nissan Titan XD Diesel
Joined
·
28 Posts
Recently bought a 2016 Titan. Well the low fuel pressure service fuel system warning came on. Replaced both fuel filters and primed system as required. Now it’ll start but it cranks numerous times before it does, the fuel system warning is still on and when i drive it just a few miles the check engine light comes on along with reduced power. Everything I’ve been reading I’ve come to the conclusion it’s a lift pump issue?? I want to order one but 900$ without knowing for sure is a lot. Any ideas?
You do realize that each priming instance needs to be at least 90 seconds, right? If you're not priming for at least 180sec, you're doing it wrong.
 

·
Registered User
2016 Nissan Titan XD Diesel
Joined
·
28 Posts
If you or someone changed the filters WITHOUT disconnecting both battery negatives, your pump was damaged.
Same thing happened on my 2016 XD. Mine ran for a week before crapping out. Put the new pump in, end of problems.
I read that the 2016 pumps had issues and were easy to damage. The replacement pump was a newer model.

If anyone has a good diesel mechanic in the Los Angeles area please let me know.
Stay away from Top Notch Diesel. About 2 years ago they were great. All the old management is gone.
The new crew is,,, I'd rather not say. Just beware.

Good luck with your truck!

I and many others have changed the fuel filters many times without disconnecting the battery terminals. It sounds like they made a quick buck off of you.

The priming procedure needs to be at least 90seconds for each instance of priming (need to do it x2 at least). If you weren't doing that, then that is what caused it, it sounds like you had some residual air in your fuel system.
 
1 - 2 of 2 Posts
Top