Nissan Titan XD Forum banner
1 - 20 of 123 Posts

·
Registered User
Joined
·
65 Posts
Discussion Starter · #1 ·
I have a gas Pro4x with 700miles on it had 38 when I drove off the lot.

Just curious if any one else noticed when light ecelerating from a complete stop, transmission shifts 1, 2, maybe 3 then just goes flat rpms come down from 2500-3000 to 1500 and truck feels like it has a dead spot between 2nd 3rd or 3rd an 4th. I come from driving an FJ cruiser for 10 years and didn't seem to have any hesitation in any gear. Now I did also noticed hard ecelerating from a stop it doesn't to it as bad but there is still a slight lag after 1st an 2nd can't tell if it does it 3rd or 4th.

Hopefully the transmission learns itself to my driving and I don't have a potential probably down the road. I seemed to be babying the truck little more than hard driving but. This transmission isn't new and the only thing I come across was an article some where saying that they just retuned it for the XD

Thanks for reading and welcome any responses. By the way instill absolutely love my truck. And have owned Nissan vehicles in the past and Infiniti. Not new to nissan.

Sent from my XT1254 using Tapatalk
 

·
Registered User
Joined
·
1,979 Posts
The tranny needs to learn your driving style & you will get used to its qwerks. So give it some time to see if it adjusts. The Dodge guys have been dealing with the Trans for several years now & they complained about the same shifting weirdness but it seems to clear up.
 

·
Registered User
Joined
·
78 Posts
he has the gas with the 7 speed AZPRO.. not the Dodge one.. but yes you are right about the learning curve.. mine took about 3000 miles to get smart.. but every once and a while it shifts a little too quick to the next gear
 

·
Registered User
Joined
·
1,300 Posts
Get your foot into it and see what it does.
Go into manual mode and slowly bring up the rpm and manually shift it, see what it does.

My tranny was good and than all of a sudden @ 14000km, I had a some funky shifts between 1 and 2, it would shift at 1700rpm with my foot hard down and than it would stumble than shift. Went to the dealer and they reflashed the trans and now it seems to be good. Shifts at 2200-2400 now so it's a lot better.
 

·
Registered User
Joined
·
577 Posts
Most automatics shift pretty weak. After a tune, my 5.0 with the 6r80 was a completely different truck. It was not the whopping 9 hp that made a difference for the gasser, but the new shift strategy. It Nissan has the solution instead of shelling out for an aftermarket one, all the better.
 

·
Registered User
Joined
·
65 Posts
Discussion Starter · #7 ·
After putting my foot into it it is a little better but it is still there. Normal driving conditions. I can replicate it every time. I will have to bring the truck in for my alignment it pulls to the right so I will at the very least show this to them not sure what they could do. It doesn't feel normal. I am a mechanic/machinist by trade and have worked on my fair share of all the of vehicles. This to me should happen. I will be waiting till I hit about 2k miles if nothing. Changes its going in.

Sent from my XT1254 using Tapatalk
 

·
Registered User
Joined
·
58 Posts
I'm curious if anyone with the Gasser, 7spd in the 1/2ton Titan is having this problem, like my wife is in her '17 Armada:

light throttle at speed (40-50mph, 1200-1500rpm)
transmission seems to be in 7th... Trying to accelerate slightly, and it feels like it thumps from 6-7-6-7-6-7. You can hear and feel it.

Going to try and take it to dealer tomorrow... Only 2300mi on it. :(
 

·
Registered User
Joined
·
577 Posts
@fifthcir - My Cx-9 used to thump between 5th and 6th at 40 MPH. The dealer said it was what they were suppose to do, which was kind of annoying.

There are some XD owners here that complain of how there 7-speed doesn't shift into 5th until 40 mph (1900 rpm or so) where as your Armada tries to shift into 7th at 40 mph (1200 rpm).

Seems they have some bugs to work out on the 7-speed. Who knows if there will be a fix for it.
 

·
Registered User
Joined
·
57 Posts
Yes mine and others do the same thing. It really only happens under light throttle, say when stuck in traffic and can only go as fast as the traffic accelerates. It is very annoying and I hope Nissan comes out with a flash to address it.

Don't count on it "learning" its way out of it. 7k miles later mine still does it, if anything its worse.

Manually shifting takes care of it. Recently when in city traffic I just put it in 3rd so it won't go to 4TH until I manually shift it or it hits redline :)
 

·
Registered User
Joined
·
65 Posts
Discussion Starter · #11 ·
Mine has 4300 miles now and I still have an issue not as noticeable as it was early on.o only reason I haven't been back again yet is I am busy with normal daily life. It is a hassle to leave my new truck with the dealership. I can't speak bad about my dealership they loaned me another xd the first time. But I don't suspect that will happen every time. I will just have to bite the bullet again to take it in was trying to wait till my first oil change. Plus I have a problem with my subwoofer under passenger seat. Sounds like I have a little bird living in it lol.

The transmission definitely has an issue. From my experience the dealership doesn't have enough in the system to go on for our transmission. So until more people bring there's in for the same thing or similar issue we will have to suffer thru it.

We did discuss shop manager and I about driving another gas xd to see if we noticed the same problem. So I may ask to drive one when I drop mine off.

Now the other thing is how they would connect a service issue from different models even though it has the same transmission. I could be wrong but when they look up issues it's for your vehicle model and that problem. Not transmission issue in Armada and transmission issue in Titan xd or Titan not sure if it overlaps in the system.

Sent from my XT1254 using Tapatalk
 

·
Registered User
Joined
·
105 Posts
I only have 800 miles on mine since it is a spare vehicle. I have really baby'd it since I am still in the break in period. When I drive like a grandpa, the tranny upshifts too soon. If I put my foot into it, the truck acts like a stallion. I am really digging on pushing it a little enjoying the acceleration!

Where I think this truck really shines it at high speeds. It it so smooth I look down and I am going 85-90 mph and it feels like I am cruising at 65. Very confidence inspiring for sure! I am sort of getting used to the size of it- except when parking at malls. It is Trump-like HUGE!
 
  • Like
Reactions: TitanCowboy

·
Registered User
Joined
·
1,098 Posts
Now the other thing is how they would connect a service issue from different models even though it has the same transmission. I could be wrong but when they look up issues it's for your vehicle model and that problem. Not transmission issue in Armada and transmission issue in Titan xd or Titan not sure if it overlaps in the system.

Sent from my XT1254 using Tapatalk
When we look up TSB's we search for your vehicle and problem. If their are multiple vehicles with that problem then the bulletin will list all vehicles affected. If it only applies to certain sub-models than it will say that on the bulletin. Such as a radio issue may only effect radios with Navi.
 

·
Registered User
Joined
·
58 Posts
I had a chance to drive/troubleshoot my wife's '17 Armada. It's not thumping now, but I still get the rpm surging around 1200-1500rpm.

I was incorrect in this king it was in 7th gear at 40-45mph. It's actually in 5th. Won't let me manually shift higher than 5th at that speed.

Man, I would love to have a manual transmission in both my Cummins XD and her Armada. What a fun drive they would be!!!
 

·
Registered User
Joined
·
1,979 Posts
I had a chance to drive/troubleshoot my wife's '17 Armada. It's not thumping now, but I still get the rpm surging around 1200-1500rpm.

I was incorrect in this king it was in 7th gear at 40-45mph. It's actually in 5th. Won't let me manually shift higher than 5th at that speed.

Man, I would love to have a manual transmission in both my Cummins XD and her Armada. What a fun drive they would be!!!
For about 2 weeks then it becomes unfun.
 

·
Registered User
Joined
·
6 Posts
I'm curious if anyone with the Gasser, 7spd in the 1/2ton Titan is having this problem, like my wife is in her '17 Armada:

light throttle at speed (40-50mph, 1200-1500rpm)
transmission seems to be in 7th... Trying to accelerate slightly, and it feels like it thumps from 6-7-6-7-6-7. You can hear and feel it.

Going to try and take it to dealer tomorrow... Only 2300mi on it. :(

I have a '17 Half ton and have this issue. Basically it seems like the truck upshifts and then immediately regrets the upshift and starts revving up to allow a downshift. It whomps, or thumps, a few times after each upshift. Its most noticeable on up-hills because I feel the surge in power and then the hesitation.


I made an appointment with my dealer, they didn't seem to be very happy with having to see a truck with less than 350kms on it (210 miles) but the issue is annoying!


I want to know if anyone else has this as well!!
 

·
Registered User
Joined
·
1,979 Posts
I have a '17 Half ton and have this issue. Basically it seems like the truck upshifts and then immediately regrets the upshift and starts revving up to allow a downshift. It whomps, or thumps, a few times after each upshift. Its most noticeable on up-hills because I feel the surge in power and then the hesitation.


I made an appointment with my dealer, they didn't seem to be very happy with having to see a truck with less than 350kms on it (210 miles) but the issue is annoying!


I want to know if anyone else has this as well!!
The whole thread is basically about that.
 

·
Registered User
Joined
·
348 Posts
I just turned 10,000 miles on mine. Build date of 4/16. Had the 2 to 4 issue with truck going blah and falling on it's face. Had the "flash" done at 8800 mi. it did not cure the problem, completely. The truck still goes from second and bounces at third only to fall into fourth at 1200 RPMs going 20 mph, the difference is that, while it of coarse feels like the truck has slowed, it is actually still picking up speed at about the same rate as it was. In other words a smooth transition up to about 45 mph. That is where I end up with the gas pedal position I start at from stop. Does that make sense?
I think the flash addresses torque management more that shift points. But I would recomend it.
Oh, and I definately noticed a change for the better while towing, better down shifting, smoother shifting, and again, seemed like better torque in upper gears.
 

·
Registered User
Joined
·
705 Posts
I haven't done much research on the gassers, but I thought I remembered reading somewhere that the gassers borrowed the engine and 7 speed tranny from the QX80, right? Unless they redesigned the whole thing for 17 in all models, one would think they've had plenty of time to work out the bugs on this powertrain.
 
1 - 20 of 123 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top