Nissan Titan XD Forum banner

1 - 20 of 214 Posts

·
Registered User
Joined
·
404 Posts
Discussion Starter #1 (Edited)
Started her up this morning and the check engine light came up and I could smell diesel exhaust inside the cabin at 530 miles. Ran my code reader and got P2263 turbo error code. So now I'm sitting at Nissan while they give me a Murano and my truck that I've had 5 days and 570 miles on the odo....
 

·
Registered User
Joined
·
404 Posts
Discussion Starter #4
A lot of idling. I'm a construction manager so I drive around the community and hop out here and there to check on homes. Average probably 20mph throughout the day
 

·
Registered User
Joined
·
404 Posts
Discussion Starter #5
Also the mpg seemed to drop today. Yesterday I was averaging 15mpg or so driving around at work
 

·
Registered User
Joined
·
857 Posts
Might be a good chance with more mileage that it will go up, but with you already at 500+ I would have expected better at this point.
 

·
Registered User
Joined
·
404 Posts
Discussion Starter #9
Just picked it back up. Apparently the intercooler piping clamps were loose from the factory and they said it's an issue that Nissan is aware of.
 

·
Registered User
Joined
·
1,300 Posts
Exhaust smell in the cab could be from a regen, mine just went threw one yesterday and I did get a hit of stank exhaust in the cab, nothing to be worried about tho
 

·
Registered User
Joined
·
363 Posts
Stinky diesel exhaust fumes in the cab is a no go for my family. I had that problem in the past and the dealer punted saying "can't duplicate." Needless to say I got rid of the problem.
 

·
Registered User
Joined
·
1,300 Posts
Hahahah that is great
 

·
Registered User
Joined
·
19 Posts
I brought mine home last night and realized the tail bed doesn't open I can hear it lock and unlock and the handle doesn't engage. Have you heard of anyone else having that issue?
Xd sl 4x4 black
 
1 - 20 of 214 Posts
Top