Nissan Titan XD Forum banner

41 - 57 of 57 Posts

·
Registered User
Joined
·
19 Posts
I checked Crutchfield the other day...there isn't a module available to interface with the steering wheel controls and camera yet. There are install kits available but those features will not work.

Factory amp would still work.
Crutchfield now has harness to retain just about all controls. Think you need a module to retain steering wheel controld
 

·
Registered User
Joined
·
1 Posts
I have a 2017 XD Pro4x. I had a new KENWOOD head unit installed about 3 weeks ago at CarToys in Plano Tx. Steering wheel controls could not be configured during the initial install, but with the dedication of the install team and a few phone calls to Axxess, everything is working, in my opinion, better than factory. The source button scrolls through option, vol, channel/skip, phone answer and hang up, plus Siri on long press of phone answer. The trick to the whole thing was, the installation instruction have you ground all wires but the blue and pink, but the blue/grey wire has to remain ungrounded. Then complete the learning procedure and you are in business. This thing works like a charm and no interference with the cluster display. Thanks to my guys at CarToys.
 

·
Registered User
Joined
·
19 Posts
I spoke with a crutchfield rep the other day and put together a package for my titan xd. I keep oem camera, amp, and steering wheel controls. I looked at a few options from the alpine halo 9, a kenwood with gps and replacing everything but the head unit and maintain all factory functions. This is the one i think im going to do for my truck. But that alpine 9 in screen looks like it would be a great match for the truck. Every option is plug and play except the last. If you keep the head unit you can go to navtool and get a plug and play module for apple carplay
 

·
Premium Member
Joined
·
88 Posts
Please keep us in the loop with your install. My main concern is maintaining all the steering wheel controls and not losing any of the factory information in my SL. I have the RF audio system and would remove the factory HU, AMP and Sub. I would install a new HU (Alpine INE-W987HD) with a new 120W x 4 channel amp (Alpine X-A70F) and new 10" self-powered subwoofer (JL Audio ACP110LG-TW1). I would run new wires from the speakers to the new amp and just leave the factory speaker wiring in place and unused. For the new HU - I would like to connect the factory back-up camera, USB port, SAT radio antenna, steering wheel controls and pull power from the factory wiring harness.

I need to get a HU in this truck that can decode lossless FLAC files - before I go crazy!
 

·
Registered User
Joined
·
8 Posts
The steering wheel controls work with the ASWC-1 from Axxess, you just need to do a full program. The tech support guys can help you with that. I put up a post with a video of mine working. The USB Port is also easy all you need is a jumper with a usb mini end on it which are available everywhere. I'm not sure on the cameras as mine didn't have any on it.
 

·
Registered User
Joined
·
181 Posts
I didn't lose any of the info for oil change, tire rotation, etc. The steering wheel controls can be made to work. Check out the Facebook group on Titan Cummins owners for a recent write-up. I also got the Idatalink to work as well.
How did you get the idatalink to work? Did you use the Maestro?
 

·
Registered User
Joined
·
1 Posts
Has anyone had any success hooking up a steering wheel controller in the S trim package? Have a 2017 XD and changed head unit however still no luck with getting my steering wheel controls to work. Had an installer try both the Axxess and I believe a PAC unit, neither of which worked. Any help would be appreciated.
 

·
Registered User
Joined
·
8 Posts
Has anyone had any success hooking up a steering wheel controller in the S trim package? Have a 2017 XD and changed head unit however still no luck with getting my steering wheel controls to work. Had an installer try both the Axxess and I believe a PAC unit, neither of which worked. Any help would be appreciated.
I have a post on here about it. The Axxess works in my S 2017. Just needs full program to work. The axxess guys can talk you through it on the phone.
 

·
Registered User
Joined
·
1 Posts
I have a post on here about it. The Axxess works in my S 2017. Just needs full program to work. The axxess guys can talk you through it on the phone.
For reference, what color wires did you tap for the axxess install? Planning on doing it this weekend.
 

·
Registered User
Joined
·
3 Posts
I got the Alpine Halo 9 installed. I don't have steering wheel controls functioning yet. I got the wiring diagram from Nissan so hoping the Alpine rep and his tech contact can figure it out.

here's a link to the Halo

9-Inch Alpine Halo9 Mech-less Audio/Video Receiver


There's a way to program the unit so you can mirror your phone while driving. The unit is a really nice upgrade from factory, if you have the RF system I'd be skeptical of getting this. The installer had a tough time wiring, and the sound is much louder on dash speakers. It'll take some tweaking to get the sound good. The backup camera looks much cleaner.
I got my steering wheel controls to work. Let me know if you need help. Did you retain your 360 camera?
I didn't lose any of the info for oil change, tire rotation, etc. The steering wheel controls can be made to work. Check out the Facebook group on Titan Cummins owners for a recent write-up. I also got the Idatalink to work as well.
do you have information on how to make the Idatalink work?
 

·
Registered User
Joined
·
11 Posts
I posted this on another thread, and hope this helps. I got a '17 XD SV, gas. regular cab. I got my steering wheel control to work by following the Troubleshooting section on the Axess vehicle specific instruction. https://metradealer.com/files/aswc/AXSWC_INST_855.pdf

As a first time installer, I mistakenly put the 3.5mm connector on the AUX jack of the new Pioneer 2550nex head unit. That connector needs to go to the W/R (wired remote) jack. Then push in and out several times to loosen up the jack, and then push it in hard the last time. (.....that's what she said)

Then, I removed the T taps on Pin 11 and 12 that I used to connect to the ASWC-1 pink and blue/pink wire because the T taps apparently added resistance. I soldered the connections where the T taps were. I also added the 68 ohm 1/4 resistor between the ASWC-1 pink and blue/pink wire that I cost $0.10 each, but the shipping was an outrageous $7.99!!!!

Then everything worked!
 
41 - 57 of 57 Posts
Top