Nissan Titan XD Forum banner

1 - 2 of 2 Posts

·
Premium Member
Joined
·
1,576 Posts
Discussion Starter #1
Pretty much at 7000km now. Non towing mpg 70% hwy and 30 % town sitting at
20 mpg average. Just coming out of winter.
Truck hasn't missed a beat. Still my only complaint is how dirty it gets. Waiting for egr flares. Im still not convinced I'm done with the smell in the cab on regen when in a stop and situation. But we will see.
It was mentioned in another thread that it likes to be driven. The quicker you get up to speed and level off the better on fuel it is.
I get questioned on it at pretty much every diesel fill up.
Regen average is now around 1500km. I have put 9.5L of def in it too date. Overall very happy. Sorry that some guys are having some issues. But I just got rid of my 2015 f150 because of all the issues and that was a late run truck.
 

·
Registered User
Joined
·
167 Posts
Pretty much at 7000km now. Non towing mpg 70% hwy and 30 % town sitting at
20 mpg average. Just coming out of winter.
Truck hasn't missed a beat. Still my only complaint is how dirty it gets. Waiting for egr flares. Im still not convinced I'm done with the smell in the cab on regen when in a stop and situation. But we will see.
It was mentioned in another thread that it likes to be driven. The quicker you get up to speed and level off the better on fuel it is.
I get questioned on it at pretty much every diesel fill up.
Regen average is now around 1500km. I have put 9.5L of def in it too date. Overall very happy. Sorry that some guys are having some issues. But I just got rid of my 2015 f150 because of all the issues and that was a late run truck.
I agree, it seems better to get on it then level off for fuel economy. Also seems to go through less regens if you get on it once in a while. I was hesitant at first until I had some miles for break in and now I push the accelerator a little harder. Highway economy is good if you can get it on cruise control as well. I've been very pleased with the truck so far, fit and finish on mine has been great. haven't had any of the idle issues that a couple others mentioned. Just the 4WD error which seems to be fixed by magic fairy dust at the dealership. I think it was just a wire connection not fully plugged in.
 
1 - 2 of 2 Posts
Top