Nissan Titan XD Forum banner
1 - 9 of 9 Posts

·
Registered User
Joined
·
1,342 Posts
Discussion Starter · #1 ·
First, my 2016 P4X truck is deleted and tuned and has 100k on the clock. About 50k since the delete and tune. I was driving on the highway when the check engine light came on. Truck kept running fine, all gauges seemed normal, but mpg seemed a little low...
I couldn't check the code until 2 days and 500 miles later. P020C is "Cylinder 3 Injection Timing" according to my OBD scan tool.... So, what is the story on this? Any insight would be appreciated.
Thanks!
 

·
Registered User
Joined
·
620 Posts
There have been a couple of reported injector failures from owners on the forum. I'd bet injector has gone kaput but there has been at least one very vocal report of a failure in the wiring harness causing it to ground out leading to the symptoms matching an injector failure. I would ask the mechanic to diagnose for BOTH possibilities even if they charge a bit extra for the labor.



Sent from my SM-N960U using Tapatalk
 

·
Registered User
Joined
·
620 Posts
Just a word of caution regarding the extra driving after the fault was detected,

just like many engines, it will continue to operate with various different misfiring conditions in one or more cylinders, however depending on the type and severity of the condition it may be causing harm to that cylinder and continued operation may lead damage or failure. It can be very disheartening to find that what you thought was a minor fueling problem resulted in damage to the piston head or valves and you are faced with a tear-down to replace those parts instead of just swapping out an injector (personal experience).

I'm hoping you are just facing a quick injector replacement.



Sent from my SM-N960U using Tapatalk
 

·
Registered User
Joined
·
1,342 Posts
Discussion Starter · #4 ·
Yeah, didn’t want to continue driving, but really had no choice. Will have to drive it to the dealer (50 miles) tomorrow and drop it off. I’ll let you know what they say.
Thanks for the reply and I will have them check for the wiring harness issue too.
 

·
Registered User
Joined
·
1,342 Posts
Discussion Starter · #5 ·
Well, I took the truck in yesterday to the dealer near my home. I have never gone there before. I usually go to the one near my office 50 miles away. But, to save driving with this code, I went to the nearest dealer. After keeping the truck all day, they told me they wouldn't work on it unless I put the tune back to factory. I took the truck to my regular dealer this morning and I'm waiting to hear from them now. I'll update when I hear something.
 
  • Like
Reactions: rexey

·
Registered User
Joined
·
1,342 Posts
Discussion Starter · #7 ·
Did you ever get it fixed? Did you find a shop? I am contemplating doing the delete or taking a huge loss on a trade in due to a failed SCR (technician thinks.)
Yes, I did get it resolved at the dealer. Sorry I didn't update the post.... My regular dealer is real good....he doesn't care about my tune and just smiles when I come in. Anyway, he said that he needed to update some code, which he did and then he shut off the check engine light. It's been 40,000 miles since that happened and no recuurrance of the code.
 

·
Banned
Joined
·
136 Posts
I guess after my failed Turbo, failed EGR valve, Failed fuel injector and a couple of other items covered under warranty my dealer, who by the way as well as all 6 of the Nissan dealers in Louisville got rid of all their Diesel Technicians except 1. By the way when the injector failed it did not throw a CEL I just lost all acceleration on a on ramp to a busy highway.. I pulled over and looked under the hood and then under the truck.. after I turned the truck back on. There was so much fluid flowing over the transmission, and I initially thought it was a water coolant line, it looked like a fast flowing waterfall. That was fixed under warranty, after repair I got to my house and found loose bolts laying on the side of the engine where the glow plugs are. Worried that something was loose I had it towed the 25 miles back to the dealer.. Fun truck, just glad I was never out somewhere with no cell phone coverage or service nearby.. with Grandkids in the truck on a freezing day or in the desert, or similar situations. Those are the reasons I only have 23,000 miles on truck I have had for 3 years. My wife wants me to sell at a big loss to buy a truck we can use more..!
 

·
Registered User
Joined
·
1 Posts
First, my 2016 P4X truck is deleted and tuned and has 100k on the clock. About 50k since the delete and tune. I was driving on the highway when the check engine light came on. Truck kept running fine, all gauges seemed normal, but mpg seemed a little low...
I couldn't check the code until 2 days and 500 miles later. P020C is "Cylinder 3 Injection Timing" according to my OBD scan tool.... So, what is the story on this? Any insight would be appreciated.
Thanks!
What dealer did you take it to? I have the same problem so i took it to a dealer and they told me the same thing that i have to put everything back to stock before they can do anything.
 
1 - 9 of 9 Posts
Top