Nissan Titan XD Forum banner

1 - 6 of 6 Posts

·
Registered User
Joined
·
2 Posts
Discussion Starter · #1 ·
Had my 2017 PR diesel with 70k at a traffic light and when i went to pull out my check engine lite and wheel slip lite go on and truck wouldn't respond to fuel pedal being pushed, so i limped it into a parking lot and shut it off for a few minutes restarted and wheel slip lite went off but check engine lite stayed on for a few miles before going off. Any ideas why this happened and i have not had time to check for a code. Thanks
 

·
Registered User
Joined
·
168 Posts
Unfortunately pulling the code(s) will be your best bet. There are too many possibilities for what it might be with such little information to go off of. But I will say that this is the first time I'm reading about someone who has a traction loss light come on when not actually losing traction. Hopefully it's nothing serious!
 

·
Registered User
2019 XD SV 5.6L
Joined
·
42 Posts
One possible reason (again, need the actual code to know for sure) is a code P2138 which has to do with the sensors in the accelerator pedal. The accelerator pedal isn't physically connected to the throttle (or whatever substitutes on a diesel). It's electronic with sensors to measure your pedal position. There's two of them and if they're out of spec even for an instant, the computer will set 'fail-safe' mode and the CEL. You can clear the fail safe mode by cycling power I found (assuming the sensor issue was just a blink) and the CEL will go off after another 3 engine starts assuming the error doesn't come back.

My dealer has been chasing this problem for a month now. They replaced the pedal and sensors but that didn't fix it. Truck's going in on Tuesday and the dealer has a call setup with the tech line to try and troubleshoot.

Probably lots f other errors can produce the same symptoms - that's just one I know for sure.
 

·
Registered User
Joined
·
2 Posts
Discussion Starter · #4 ·
One possible reason (again, need the actual code to know for sure) is a code P2138 which has to do with the sensors in the accelerator pedal. The accelerator pedal isn't physically connected to the throttle (or whatever substitutes on a diesel). It's electronic with sensors to measure your pedal position. There's two of them and if they're out of spec even for an instant, the computer will set 'fail-safe' mode and the CEL. You can clear the fail safe mode by cycling power I found (assuming the sensor issue was just a blink) and the CEL will go off after another 3 engine starts assuming the error doesn't come back.

My dealer has been chasing this problem for a month now. They replaced the pedal and sensors but that didn't fix it. Truck's going in on Tuesday and the dealer has a call setup with the tech line to try and troubleshoot.

Probably lots f other errors can produce the same symptoms - that's just one I know for sure.
Thanks ! Let me know if they find anything !
 

·
Registered User
Joined
·
20 Posts
That happened to me and it was a turbo controller and it would bring in engine light and traction control light
 

·
Registered User
Joined
·
86 Posts
Had my 2017 PR diesel with 70k at a traffic light and when i went to pull out my check engine lite and wheel slip lite go on and truck wouldn't respond to fuel pedal being pushed, so i limped it into a parking lot and shut it off for a few minutes restarted and wheel slip lite went off but check engine lite stayed on for a few miles before going off. Any ideas why this happened and i have not had time to check for a code. Thanks
Literally happened to me this morning. Exact same thing. I drove about 140 miles afterwards. Problem never returned.
46347
 
1 - 6 of 6 Posts
Top