Nissan Titan XD Forum banner

1 - 11 of 11 Posts

·
Registered User
Joined
·
34 Posts
Discussion Starter #1
Just got back from an RV camping trip and noticed the distance to empty was not matching my fuel gauge. The fuel gauge was just over 1/2 tank, with the Distance to empty showing 92 miles. After storing the RV I headed to the pump to fill her up, Distance to empty now only shows 260 mi, normally shows 360(ish) with a full belly. Anyone else with a Gasser experience this problem?
 

·
Registered User
Joined
·
145 Posts
I don't have a gas XD, but I expect similar applies.

You were towing the RV during that trip, right? If so, your mpg was significantly less than your normal drives, right? The computer calculates DTE by using recent average mpg. Now that you are not towing the RV, it will start to get the better mpg into the equation. I don't expect that you'll see the DTE climbing, but you will probably see miles last longer. By the next fill, DTE should be back to normal.
 

·
Registered User
Joined
·
34 Posts
Discussion Starter #4
Thanks appreciate the info. I do not remember seeing the discrepancy during our last RV trip, and will certainly keep an eye out. Thanks again....
 

·
Registered User
Joined
·
103 Posts
I have a gasser and also sometimes see the problem when towing also, I'm not sure why it happens, sometimes it resets to the correct, others it takes a few tanks. I've tried to reset the mpg counter and it doesn't seem to effect it.
 

·
Registered User
Joined
·
1,517 Posts
My diesel had done it twice so far. It might show 100 miles less but if you reset your trip and watch it and compare to dte counting... the dte guage will not count down every mile... it drops 1 mile every 2 miles on the trip counter. I sure hope this makes sense lol
 

·
Registered User
Joined
·
2 Posts
You are not the only one with the problem, since purchased I have had the issue with my 2019 XD. I have taken it to dealers on multiple occasion shown them pictures, etc. To be honest Nissan is clueless of the problem, I am glad others are having same issue, they just keep ignoring or don't even test because they only go by the computer codes. Computer is not has not logged errors, so to them no issue is present. After some time they have swapped out gauge console, and replaced the fuel pump / float (its a single unit) but has not fixed the issue. Attached is a current picture of the truck with a full tank of gas but --- for remaining mileage for the full tank of gas. Note the only was I have found to reset and what I take is what he dealer does every time is either reset the center console gauge with a re-flash or pull battery cable and re-plug back _ those are the only 2 ways I have seen the unit reset and calculate mileage to empty correctly. I had open case with Nissan Corp. still out standing but to them, no real support provided, they tend to just print out some some random paperwork about here i
45525
s the reason about towing ( haven't towed anything) or that the tank should always have a minimum of 4 gallons (not the case here either).
 

Attachments

·
Registered User
Joined
·
659 Posts
If you just "top off" the Titan the DTE counter will not reset. It has to see a large increase in fuel level in order to reset itself, otherwise it will just continue counting down. It's pretty dumb, but that's what I've observed. If my fill-up is any less than 15 or so gallons (50 gallon tank) the DTE stays where it was.
 

·
Registered User
Joined
·
2 Posts
Considering the DTE Counter and my original post, this is just additional information. I had a 2018 Titan XD I could fill up 4 gallons to half a tank never had an issue, but with my 2019 filling up the same way it performs I s completely different manner. If I fill up half a tank to 4 gallons, etc. it resets and calculates at random and sometimes not all. I recently also just ran across another post that the Nisan Rogue does the same thing (Nissan Rogue Questions - distance to empty not resetting - CarGurus) some one noted the 2019. Note disconnecting the battery and reconnecting is not a solution just resets all the instruments and issue continues, also dealerships tend to reset the instrument console again not a solution since the onboard computer never logs an issue.
 
1 - 11 of 11 Posts
Top