Nissan Titan XD Forum banner

1 - 7 of 7 Posts

·
Registered User
Joined
·
5 Posts
Discussion Starter #1
2017 XD, has 4200 miles on it and runs like crap. Going in to dealer for the 2nd time, no codes just completely not right, hesitation, load valve rattle, clunky rear end, transmission shifts all over the place and lose of power on acceleration, drives like a old beat truck, not a new 45,000 dollar truck, really starting to regret trading my Silverado. I do love the look and seats but I am really questioning the overall build quality, I owned a brand new 04 titan with the same engine and it was truly a new vehicle for nissan then but it was better than this, if things dont get fixed right this time, Im trading it in and will never buy another nissan product. I'm really beginning to feel like I was raped.

Sent from my SM-N950U using Tapatalk
 

·
Registered User
Joined
·
629 Posts
Sorry to hear about it bud, but what if you got bad fuel? Hard to say without seeing the dealership.

Keep us posted.
 

·
Registered User
Joined
·
897 Posts
2017 XD, has 4200 miles on it and runs like crap. Going in to dealer for the 2nd time, no codes just completely not right, hesitation, load valve rattle, clunky rear end, transmission shifts all over the place and lose of power on acceleration, drives like a old beat truck, not a new 45,000 dollar truck, really starting to regret trading my Silverado. I do love the look and seats but I am really questioning the overall build quality, I owned a brand new 04 titan with the same engine and it was truly a new vehicle for nissan then but it was better than this, if things dont get fixed right this time, Im trading it in and will never buy another nissan product. I'm really beginning to feel like I was raped.

Sent from my SM-N950U using Tapatalk
The engines between the 04 and 17 are not even close to being the same. I suspect the engine noise you are hearing is from the injectors and is due to it being a direct injected engine. As far as the shifting and engine performance there may be software updates for those concerns.
 

·
Registered User
Joined
·
59 Posts
My truck (3600 miles) never ran the way that it should have. Last week, I had an issue where the MIL light came on and it started to idle rough, wouldn't shift right, no power, etc. etc. I had it towed to the dealer and it was a bad ECM. They replaced it (there is a TSB for replacing them)...and according to my service advisor, this is a brand new, totally reprogrammed ECM due to the issues of lag, poor shifting, etc. In any event, it was replaced, reflashed everythig to match and let me tell you, it is like a brand new truck with a beast of power. I got it back on Thursday and since then, it has been shifting so much smoother, more often on grades (no lag) and is just more responsive overall. Even my service advisor said that when the Tech took it for a 10 mile test drive on hills, etc., he came back and said that thing is a beast and this is how the truck should run.

Maybe this is something you need to mention to your service advisor.
 

·
Registered User
Joined
·
326 Posts
Defiantly sounds like a software issue. Could be a bad ECM too.

I have had my 2017 since Oct 9th and just turned over 4600 miles. I drive it hard and it is a work truck. No issues. The down shift from 3rd to 2nd is a little wired but I figured it out and I have no issues with it.
 

·
Registered User
Joined
·
769 Posts
My truck (3600 miles) never ran the way that it should have. Last week, I had an issue where the MIL light came on and it started to idle rough, wouldn't shift right, no power, etc. etc. I had it towed to the dealer and it was a bad ECM. They replaced it (there is a TSB for replacing them)...and according to my service advisor, this is a brand new, totally reprogrammed ECM due to the issues of lag, poor shifting, etc. In any event, it was replaced, reflashed everythig to match and let me tell you, it is like a brand new truck with a beast of power. I got it back on Thursday and since then, it has been shifting so much smoother, more often on grades (no lag) and is just more responsive overall. Even my service advisor said that when the Tech took it for a 10 mile test drive on hills, etc., he came back and said that thing is a beast and this is how the truck should run.

Maybe this is something you need to mention to your service advisor.


Have the tsb #?


Sent from my iPhone using Tapatalk
 

·
Registered User
Joined
·
59 Posts
My truck (3600 miles) never ran the way that it should have. Last week, I had an issue where the MIL light came on and it started to idle rough, wouldn't shift right, no power, etc. etc. I had it towed to the dealer and it was a bad ECM. They replaced it (there is a TSB for replacing them)...and according to my service advisor, this is a brand new, totally reprogrammed ECM due to the issues of lag, poor shifting, etc. In any event, it was replaced, reflashed everythig to match and let me tell you, it is like a brand new truck with a beast of power. I got it back on Thursday and since then, it has been shifting so much smoother, more often on grades (no lag) and is just more responsive overall. Even my service advisor said that when the Tech took it for a 10 mile test drive on hills, etc., he came back and said that thing is a beast and this is how the truck should run.

Maybe this is something you need to mention to your service advisor.


Have the tsb #?


Sent from my iPhone using Tapatalk
I don't have the number or the truck anymore. Had other issues and got rid of it for a 2018 GMC 2500 HD Denali.
 
1 - 7 of 7 Posts
Top