Nissan Titan XD Forum banner

1 - 20 of 21 Posts

·
Registered User
Joined
·
903 Posts
Discussion Starter #1
Was just driving my pro4x home in the snow and service engine light came on. Dash kit up WARNING SERVICE ELECTRONIC THROTTLE CONTROL. the rest of the ride home the diesel engine quit being quiet and started making a bunch of racket like a cummins in a dodge would if I got above 2rpms with it. Kinda weird. Maybe I will wake up tomorrow and everything will be fine? Not sure. Either way going into shop first of the week...429 miles
 

Attachments

·
Registered User
Joined
·
70 Posts
Wonder if its the same issue another member had a few days ago with the intercooler hoses being loose. They fixed same day while he waited I believe. He said they were aware of the problem. I know when mine comes in I'll make sure they check that in service before I drive off the lot.
 

·
Registered User
Joined
·
903 Posts
Discussion Starter #6
No service engine light today. Maybe the service fairy came in my sleep last night. Will probably just see what happens and take to dealer if it happens again. Keep everyone posted.
 

·
Registered User
Joined
·
1,300 Posts
Codes will be stored just might not be active, they will be able to see them once it's plugged in.
 

·
Registered User
Joined
·
908 Posts
I don't notice a MIL light on in your picture. If you can take it by the dealer you should let them know what happened. There may not be a code stored with this type of warning message. With new models when dealers see problems Nissan likes us to send them the information so they can identify common problems and pass it along to the engineers. Makes it quicker for bulletins to come out.
 

·
Registered User
Joined
·
857 Posts
I don't notice a MIL light on in your picture. If you can take it by the dealer you should let them know what happened. There may not be a code stored with this type of warning message. With new models when dealers see problems Nissan likes us to send them the information so they can identify common problems and pass it along to the engineers. Makes it quicker for bulletins to come out.
Thanks for bringing that up, not enough people do this and its understandable since most of us are used to just going to the dealer and dealing with the brands front line workers.

Do you come from experience on the service side or just from experience as a customer?
 

·
Registered User
Joined
·
908 Posts
Thanks for bringing that up, not enough people do this and its understandable since most of us are used to just going to the dealer and dealing with the brands front line workers.

Do you come from experience on the service side or just from experience as a customer?
I have been a mechanic for 35 years, have worked in Nissan dealerships for 17 years.
 

·
Registered User
Joined
·
903 Posts
Discussion Starter #13
Close to 1000 miles now. Mpg is improving a little now. Have had no more issues with this light. Never took it to dealer to check will wait a while yet to see if I have a problem. Reason being is my dealer is over half hour away. Just an update...
 

·
Registered User
Joined
·
903 Posts
Discussion Starter #16
I don't have any engine noise right now. This warning light went off and when I took it to the shop they didn't find any codes. However my 4wd did go out and they are replacing the transfer case. I have close to 2000 miles on it and have only had one regen. Because I was idling it too much.
 

·
Registered User
Joined
·
1 Posts
Did it to me

I had the same situation shortly after i got my XD Diesel. Driving a Forest road, very bumpy, and the warning for Electronic throttle and reduced power and loud engine noise. I drove it another 5 miles and got into a small town then shut it down. After restart it totally reset. No codes were in it after returning to the dealer and it has not happened again. Now 10,000 and pulling a 30' trailer from AZ to So Fla.
 

·
Registered User
Joined
·
194 Posts
I had the same situation shortly after i got my XD Diesel. Driving a Forest road, very bumpy, and the warning for Electronic throttle and reduced power and loud engine noise. I drove it another 5 miles and got into a small town then shut it down. After restart it totally reset. No codes were in it after returning to the dealer and it has not happened again. Now 10,000 and pulling a 30' trailer from AZ to So Fla.
Had the exact same thing happen on a forestry road just after I purchased mine. It reset its self when I turned the truck off. Have not seen since. Dealer did do the first ECM / TCM update the next day. No codes where present according to them... but that dealer has proven incompetent so who knows.
 

·
Registered User
Joined
·
168 Posts
I just received the "service electronic throttle control" warning today, after driving over some railroad tracks (500ft later). It stayed on for about 30secs and then went off. There was no performance issue or change. I have 3,200 miles on the truck. I have a 1k/mi trip coming up this weekend. I guess I'll take it to the dealer next week -maybe. Not too worried about it given the reports above.
 

·
Registered User
Joined
·
903 Posts
Discussion Starter #20
I just received the "service electronic throttle control" warning today, after driving over some railroad tracks (500ft later). It stayed on for about 30secs and then went off. There was no performance issue or change. I have 3,200 miles on the truck. I have a 1k/mi trip coming up this weekend. I guess I'll take it to the dealer next week -maybe. Not too worried about it given the reports above.
When I took mine to dealer after this happened a year ago it gave no codes. And it has not happened again. 16000 miles
 
1 - 20 of 21 Posts
Top