Nissan Titan XD Forum banner

1 - 16 of 16 Posts

·
Registered User
2016 Titan XD SL 4x4 Deleted/Tuned
Joined
·
17 Posts
Discussion Starter #1
Hey everyone, got some issues here and need to vent. For the last 5 weeks I have been fighting non stop electrical issues. Here is the order they have gone;

1.) DEF SYSTEM ERROR
2.) DEF SYSTEM ERROR
3.) Complete loss of rear brake lights
4.) DEF SYSTEM ERROR

As of right now, the truck is in a count down mode till 5 mph limp mode. I'm getting 3 codes, all are the same saying "LOSS OF COMMUNICATION TO NOX SENSOR B". Now I've done everything but replace the sensor on this error. Last time it came it was a broken pigtail connector to the DEF pump. The break lights ended up being a broken ground wire in the harness. Now I said the hell with trying to find the exact break, so I spliced in a new ground. The first DEF SYSTEM ERROR was a fluke. I have no idea what caused it.

So I guess after my rant, I'm just connecting the dots to see that it's all electrical problems on this truck. Not a single mechanical issue.

Is anyone else getting these kind of non stop electrical problems?
 

·
Registered User
Joined
·
186 Posts
I just had a NOX sensor communication error they replaced one NOX sensor and one communication box the bill would have been $985 but I just got it in right before my extended warranty expired.


Sent from my iPhone using Tapatalk
 

·
Registered User
2016 Titan XD SL 4x4 Deleted/Tuned
Joined
·
17 Posts
Discussion Starter #3
Well I do have a full bumper to bumper extended warranty for the next 5 years. Guess that'll be the next thing. I'm just getting tired of non stop DEF problems
 

·
Registered User
Joined
·
569 Posts
Well I do have a full bumper to bumper extended warranty for the next 5 years. Guess that'll be the next thing. I'm just getting tired of non stop DEF problems
To be clear, you are NOT having "non-stop DEF issues." What you are having are various electrical wiring and components issues (unless there is something else you haven't passed on to us yet). As an additional aggravation it often happens that first things that are "fixed" don't always turn out to be the thing that was causing the problem.

Although there have been sporadic reports of individual electrical or wiring faults no one has reported repeated failures cropping up all over the truck. The only occasions I have ever witnessed of something like that has been with flood/water damaged vehicles (often snuck onto the market w/o disclosing said water issue.)

If it is still under warranty the ideal solution is take it to the dealership, document the problem(s) and let them know in direct terms that you intend for them to return to you a properly operating vehicle. It might also behoove you to start a complaint 'ticket' with Nissan Corporate customer care. This has been know to light a fire under the behinds of many a foot-dragging dealership.



Sent from my SM-N960U using Tapatalk
 

·
Registered User
Joined
·
968 Posts
The most common spot for recurring wiring issues is the body harness that runs along the frame rail. Especially water intrusion into the SMJ connector below the passenger side door. You've said you have done everything except change the sensor, what were your voltage drop readings when testing the wiring between the sensor and the ECM? Did you also take readings while wiggling the harness at the same time to check for fluctuations? If they are all within acceptable levels it most likely is the sensor. Visually inspect the sensor for any signs of damage.
 

·
Registered User
2016 Titan XD SL 4x4 Deleted/Tuned
Joined
·
17 Posts
Discussion Starter #6
Yes, the voltage was correct coming into the sensor. So I did not check anything at the main harness on the frame since I was getting power at the pigtail going to the sensor.

AAsim typing this, the truck is at my Nissan dealership going through a diagnosis. The tech took it for a drive and they gave me the "hey...you got more issues then the DEF ERROR. It feels very doggy". I am a little intrigued as to see what else could be wrong.....not. So I will keep you guys aprised as to what they find out.
 

·
Registered User
Joined
·
3 Posts
Well I do have a full bumper to bumper extended warranty for the next 5 years. Guess that'll be the next thing. I'm just getting tired of non stop DEF problems
Yeah I just found out that it doesnt cover the wastegate actuator on the turbo, or the turbo apparently. Per Nissan. I am having issues myself. About to cost me 2k for something they dont think will fix it. Per nissan. So it aint b2b. Mine certified used 72k miles had 100k mile b2b warranty so i thought.
 

·
Registered User
Joined
·
569 Posts
Yeah I just found out that it doesnt cover the wastegate actuator on the turbo, or the turbo apparently. Per Nissan. I am having issues myself. About to cost me 2k for something they dont think will fix it. Per nissan. So it aint b2b. Mine certified used 72k miles had 100k mile b2b warranty so i thought.
Note: Bumper to Bumper doesn't cover the turbo etc. but is is covered under powertrain warranty

Sent from my SM-N960U using Tapatalk
 

·
Registered User
2016 Titan XD SL 4x4 Deleted/Tuned
Joined
·
17 Posts
Discussion Starter #9
Okay so my B2B is not through Nissan. I bought mine as an extended warranty through Smart Autocare. It's a 5 year unlimited mile warranty. Called the total exclusionary warranty.
 

·
Registered User
Joined
·
3 Posts
Okay so my B2B is not through Nissan. I bought mine as an extended warranty through Smart Autocare. It's a 5 year unlimited mile warranty. Called the total exclusionary warranty.
Gotcha makes sense. The after market warranties were much better fron what i read when i was trying to find info on the nissan certified warranty.
 

·
Registered User
Joined
·
569 Posts
Gotcha makes sense. The after market warranties were much better fron what i read when i was trying to find info on the nissan certified warranty.
The "extended warranty" market is primarily a legal scam. No matter how many stories you hear about someone who saved "thousands" in repair costs the fact is most high dollar repairs that might be covered due to faults or failures occur during the manufacturers warranty period (when the aftermarket warranty doesn't have to pay) and between the exclusions, the actual cost of any repair, and the price they charge you for the warranty, you almost never come out ahead. Consumer Reports has done research on them in the past and STRONGLY recommends against them.

Sent from my SM-N960U using Tapatalk
 

·
Registered User
Joined
·
569 Posts
Yeah I just found out that it doesnt cover the wastegate actuator on the turbo, or the turbo apparently. Per Nissan. I am having issues myself. About to cost me 2k for something they dont think will fix it. Per nissan. So it aint b2b. Mine certified used 72k miles had 100k mile b2b warranty so i thought.
Yeah, the whole aftermarket extended warranty business is a scam. Between the items they "exclude" and the ones they will classify as "wear items" and the ones they'll say you caused and then the hassle of getting them to pay you plus the amounts they will pay you, you almost never get your money out of them.

Sent from my SM-N960U using Tapatalk
 

·
Registered User
2016 Titan XD SL 4x4 Deleted/Tuned
Joined
·
17 Posts
Discussion Starter #13
Well that may be true, but my warranty has already replaced my coolant reservoir, and a defective leaf spring. No money out of my pocket. They also replaced a faulty proximity sensor. I can't complain right now.
 

·
Registered User
2016 Titan XD SL 4x4 Deleted/Tuned
Joined
·
17 Posts
Discussion Starter #14
Well, they (warranty) replaced the nox sensor. But the dealership said they wanted to replace the ENTIRE harness. Warranty said no to that request. So I did an impulse buy, and bought a full delete kit.
 

·
Registered User
2016 Titan XD SL 4x4 Deleted/Tuned
Joined
·
17 Posts
Discussion Starter #15
Morning everyone, so yesterday I put the kit on...and oh my what a difference! There's no lag, power is dramatically up, and the transmission feels so much better. Drove it all evening just trying to get any error and nothing. Im going to drive it for a while more and then post up another review on it. But so far I'd recommend the kit.
 

·
Registered User
Joined
·
30 Posts
Morning everyone, so yesterday I put the kit on...and oh my what a difference! There's no lag, power is dramatically up, and the transmission feels so much better. Drove it all evening just trying to get any error and nothing. Im going to drive it for a while more and then post up another review on it. But so far I'd recommend the kit.
Could you private message me where you able to acquire a delete tune?
 
1 - 16 of 16 Posts
Top