Nissan Titan XD Forum banner
1 - 5 of 5 Posts

·
Registered User
Joined
·
134 Posts
Discussion Starter · #1 ·
I have a P0236 code that's triggering a check engine light. Online decription of this code says that the boost sesnor is returning a value that is unexpected, or not making sense compared to the MAP sensor values. I cleaned the MAP sesnor, but that did nothing.

I suspect it's just a bad sesnor. If the turbo was acting weird, I'd most likely feel a difference in the driving, but it feels normal and the fuel milage is also normal.

Before I go through the huge pain in the ass of removing the intake and EGR cooler, do any of you know which boost sesnor is sesnor A? I know there's at least 2 of them.
 

·
Registered User
Joined
·
134 Posts
Discussion Starter · #4 ·
You know, I feel like a raging idiot because I went to that site a few months ago to study the EGR system's coolant flow chart. The thought never occured to me that my answer can be found there.
 

·
Registered User
Joined
·
134 Posts
Discussion Starter · #5 ·
I've searched the "Engine Mechanical" and "Engine Control" PDF's of the manual without success. "Engine Control", which seems to have all the trouble codes and how to diagnose and fix them, metioned P0237 and P0238 for sensor A returning an abnormally low or high voltage. However, nothing for P0236: sesnor A circuit range/performance. This did tell me that it's the low pressure sesnor. Also, a provided graph of the Holset M2 system shows that it's also the only boost sensor. What I believed to be a high pressure boost sensor is most likely the high pressure turbo speed sensor. I apologize for posting bad information without further research.

I'll search the other sections of manual, but it seems "Engine Control" would have the solution, if it were anywhere in the manual. Below is the link to the manual, for anyone that wants to download it. It's very helpful and detailed.

 
1 - 5 of 5 Posts
Top