Nissan Titan XD Forum banner
1 - 8 of 8 Posts

·
Registered User
Joined
·
810 Posts
Looking good.

But it looks like you lost the rear window/side mirrors defroster?
 

·
Registered User
Joined
·
810 Posts
It's more than likely buttons on the screen now?
One of the screen shows the front defroster but the rear/side mirror defroster is not there. It'd be odd if it is on a different screen. Just saying...
 

·
Registered User
Joined
·
810 Posts
Yes, my mistake. The rear is actually on the panel when you bring up the A/C controls. Its on the right side. I looked.
That is awesome. Now I'm gonna do some sideworks to pay for this awesome looking Android HU.
 
  • Like
Reactions: roughneck9725

·
Registered User
Joined
·
810 Posts
Here it is. You see the two defrost buttons to the right of the A/C button. It's the right one above the recirculation button
Thanks, That’s it.
 

·
Registered User
Joined
·
810 Posts
Been looking at for a while to install in 17 pro4x . But have a few ? Does factory mic and steering controls .etc everything work. android auto / apple carplay all kinks fixed . Anything that dosent wrk like it should ? Would you buy/install it again or go with something else?
Everything works as advertised. On mine, it restarts once in a while while driving. But all seems okay.
 

·
Registered User
Joined
·
810 Posts
Thanks , I'm ocd. random power cycles would drive me nuts. Have you checked all wiring to make sure there's not a short?
Yup, checked dozen of times. Called and talked with technical support (US based), they sent updates but it still does it once in a while.
 
1 - 8 of 8 Posts
Top