Nissan Titan XD Forum banner
1 - 8 of 8 Posts

·
Registered User
Joined
·
1,308 Posts
Discussion Starter · #1 ·
Went to a drive thru this morning and pushed the button to lower the driver side front window and ...nothing. I then pushed the buttons for the other windows and still nothing. I checked to make sure the child safety switch was not on and it wasn't. I also noticed that I can't lock or unlock the door locks from the driver control panel either. So then I went to each door and tried to window switches and none of them work either.
I found the 50 amp main fuse under the hood and it appeared via a visual inspection to be good. I then went to the fuse panel to the right of the glove compartment and found the door lock fuses and they looked good and tested good.
The key fob will lock and unlock the doors, the problem just seems to be with the door controls.
Any thoughts on what to check next? No electrical work has been done on the truck for at least the last year....
 

·
Registered User
Joined
·
1,505 Posts
Check to see if the main harness on the driver side came loose. Maybe the window lock switch got engaged and then the harness came lose. I realize that would be a strange sequence of events but that’s all I can offer!!
 

·
Registered User
Joined
·
1,644 Posts
Has the window switch got wet from rain or anything spilled on it? Have you tried a battery disconnect and reset yet
 

·
Registered User
Joined
·
1,308 Posts
Discussion Starter · #4 ·
Has the window switch got wet from rain or anything spilled on it? Have you tried a battery disconnect and reset yet
Hey Rick!
Normal drizzle from rain if the window is open for a few seconds or the door opens in a rainstorm, but never soaked.... I have not tried a battery disconnect yet. That won't affect my tune right?
 

·
Registered User
Joined
·
1,644 Posts
Yeah your tune will be fine. Disconnect both negatives and then touch on of them to the positive and that will remove the stored memory voltage and let everything reset. Then hook both neg back up and see if that helps
 

·
Registered User
Joined
·
1,308 Posts
Discussion Starter · #6 ·
Ok, found the problem. It’s in the wiring between the left front fender and the drivers door.
I grabbed the wire loom thst goes into the drivers door and moved it around while holding the window button in the down position...BINGO! The window went down. Then I couldn’t get it to go back up until i pushed thst wire loom around some and the it eent up fine. All the other windows worked too! But i do hsve to shake the wire lom around in order for it to work.
so now I will have to open up that wire loom and find the loose connection and fix it
 
  • Like
Reactions: wakinvol

·
Registered User
Joined
·
1 Posts
Ok, found the problem. It’s in the wiring between the left front fender and the drivers door.
I grabbed the wire loom thst goes into the drivers door and moved it around while holding the window button in the down position...BINGO! The window went down. Then I couldn’t get it to go back up until i pushed thst wire loom around some and the it eent up fine. All the other windows worked too! But i do hsve to shake the wire lom around in order for it to work.
so now I will have to open up that wire loom and find the loose connection and fix it
I realize you posted this a year ago. What year is your Titan? I just bought a ‘21 xd pro4x and my windows worked intermittently. So I took it to the dealer, which they kept for 2 weeks, and they changed out the ECM I think (don’t quote me on it) and worked good for 2 days and started doing it again. Now it quit all together. I have another appointment with the dealer since it’s under warranty and I’m going to mention what you found. Did you fix the loose connection? Thanks for your post.
 
1 - 8 of 8 Posts
Top