Nissan Titan XD Forum banner

1 - 13 of 13 Posts

·
Registered User
Joined
·
5 Posts
Discussion Starter #1
I recently bought a used 2017 Titan XD with the Cummins. First time owner of a diesel engine. The next day I'm driving down the freeway and the slip light comes on and stays on. My wife has an Infinity and I've seen the light come on in her car when I mash the gas on a wet road but it blinks and turns off immediately. So when I see the light come on and stay on I knew it was not good. I pull off the freeway and and as I'm coming to a stop at the light I feel my truck lunge forward as if someone rear ended me. Light turns green I accelerate and the trans is shifting hard through 1-3 gears. I pull over and turn the truck off and the light does not come back on. It re set its self. I get back on the freeway and the light comes back on but the truck is driving good at highway speeds. Only acts up when the slip light is on coming to a stop and taking off with the hard shifts. I'm not getting on it or anything to make the slip light come on. I do notice when the light is on that the power is limited when I go to pass on the freeway. I took the truck to the Nissan dealer being it only has 18K miles. The service adviser calls me back immediately and says that my truck is not covered under warranty due to the truck being tuned and deleted and the leveling kit. I knew the truck was obviously lifted but tuned and deleted I had no idea. (Again I'm a first time diesel truck owner) I go to pick up my truck and he shows me where the EZ Lynk turner was connected and the SOFT switch that switched between tunes was. The EZ LYNK is gone. I'm guessing the previous owner took it before he traded in the truck. The dealer I bought the truck from is a small dealer here in Houston. I told them the problems I'm having with the truck and they tell me to take it to the Nissan Dealer. Well Nissan isn't covering it due to it being tuned. So the manager tells me to take the truck to his service when the light comes and to diagnose the problem. I get the light to come and so I take it over to their service department. The tech puts the scanner on the truck and codes P0106 (MAP Sensor) comes on along with P2637 (Torque Management Feedback) He tells me the MAP sensor is whats triggering the code P2637. So he replaces the MAP and he calls me that my truck is ready. I put 100 miles on it and BAM! The freaking slip light comes back on and is still shifting hard when taking off from a stop and when I make a complete stop it lunges forward. Again, these problems only happen when the slip light is STAYING ON. Between the wheel speed sensors, ABS system, and TCM I feel like this is going to be a long process to diagnose the issue. I've only seen 1 other issue similar to this one on another forum but with no solution or input on the issue. Anything would be greatly appreciated to help me narrow down the problem. Truck is leveled on 33" after market 20'' rims. Tuned and deleted (with a missing tuner module ) fml...........
 

·
Registered User
Joined
·
295 Posts
I've never had a truck with a tuner on it, so someone who has will certainly be able to answer this with more knowledge than I have. However, my first thought is that your truck's ECM is freaking out without the tuner attached and making things run smoothly.
 

·
Registered User
Joined
·
274 Posts
If your warranty is already gone then get another Ez lynk so you can at least figure out what is going on with your truck. Or you can call the few guys who tune these trucks and give them your vin number and they will tell you if they have tuned that truck or not.
 

·
Registered User
Joined
·
5 Posts
Discussion Starter #5
I've never had a truck with a tuner on it, so someone who has will certainly be able to answer this with more knowledge than I have. However, my first thought is that your truck's ECM is freaking out without the tuner attached and making things run smoothly.

Yes sir that was my initial thought myself. I contacted a guy who does tunes and he's telling me that it has to be plugged in monitoring the system at all times. I explained that to the service adviser at the dealership I bought it from and he tells me once the tune is loaded I don't have to have it. I don't know who to believe.
 

·
Registered User
Joined
·
5 Posts
Discussion Starter #6
If your warranty is already gone then get another Ez lynk so you can at least figure out what is going on with your truck. Or you can call the few guys who tune these trucks and give them your vin number and they will tell you if they have tuned that truck or not.

From the car fax the truck is out of Tennessee. I'm down here in Houston so that truck hasn't been touched by anyone here in the area. I feel like I'm going to have to break down and buy a tuner here soon to see if that will help correct the issues the trans is having causing the slip light to come on.
 

·
Premium Member
Joined
·
1,160 Posts
someone here was selling their tuner recently. Check the BUY/SELL section here or maybe look here:


You may want to ask him if it belonged in his old truck...
 

·
Registered User
Joined
·
10 Posts
I recently bought a used 2017 Titan XD with the Cummins. First time owner of a diesel engine. The next day I'm driving down the freeway and the slip light comes on and stays on. My wife has an Infinity and I've seen the light come on in her car when I mash the gas on a wet road but it blinks and turns off immediately. So when I see the light come on and stay on I knew it was not good. I pull off the freeway and and as I'm coming to a stop at the light I feel my truck lunge forward as if someone rear ended me. Light turns green I accelerate and the trans is shifting hard through 1-3 gears. I pull over and turn the truck off and the light does not come back on. It re set its self. I get back on the freeway and the light comes back on but the truck is driving good at highway speeds. Only acts up when the slip light is on coming to a stop and taking off with the hard shifts. I'm not getting on it or anything to make the slip light come on. I do notice when the light is on that the power is limited when I go to pass on the freeway. I took the truck to the Nissan dealer being it only has 18K miles. The service adviser calls me back immediately and says that my truck is not covered under warranty due to the truck being tuned and deleted and the leveling kit. I knew the truck was obviously lifted but tuned and deleted I had no idea. (Again I'm a first time diesel truck owner) I go to pick up my truck and he shows me where the EZ Lynk turner was connected and the SOFT switch that switched between tunes was. The EZ LYNK is gone. I'm guessing the previous owner took it before he traded in the truck. The dealer I bought the truck from is a small dealer here in Houston. I told them the problems I'm having with the truck and they tell me to take it to the Nissan Dealer. Well Nissan isn't covering it due to it being tuned. So the manager tells me to take the truck to his service when the light comes and to diagnose the problem. I get the light to come and so I take it over to their service department. The tech puts the scanner on the truck and codes P0106 (MAP Sensor) comes on along with P2637 (Torque Management Feedback) He tells me the MAP sensor is whats triggering the code P2637. So he replaces the MAP and he calls me that my truck is ready. I put 100 miles on it and BAM! The freaking slip light comes back on and is still shifting hard when taking off from a stop and when I make a complete stop it lunges forward. Again, these problems only happen when the slip light is STAYING ON. Between the wheel speed sensors, ABS system, and TCM I feel like this is going to be a long process to diagnose the issue. I've only seen 1 other issue similar to this one on another forum but with no solution or input on the issue. Anything would be greatly appreciated to help me narrow down the problem. Truck is leveled on 33" after market 20'' rims. Tuned and deleted (with a missing tuner module ) fml...........
I have a 2005 Titan with SLIP problems. On my truck, it won't let me go into 4WD with the slip light ON.
One time the problem was that the brake fluid was low. I added BRAKE Fluid and the light went OFF and atayed OFF.

Another time it was a bad ABS sensor. I replaced both front sensors and the light went OFF.

Once again, this was a gas, 2005 Titan, which I still have.

My diesel XD is 2016. I haven't had this problem yet....30k miles on it.
My two biggest problems have been the bolts snapped on the power steering pump and it took me two months and many hours to drill it. My "Easy outs" broke inside the engine as well as my left handed drills. I eventually bought high quality diamond bits and that is what finally worked.

My other problem is this diesel isn't "ready" to pass Massachusetts emissions....and every time I try to get an inspection sticker, they tell me to drive another 300 mile and come back.

Good luck with your SLIP problem... replace sensors and check the wiring harness and check your brake fluid...
Mike
 

·
Registered User
Joined
·
3 Posts
I recently bought a used 2017 Titan XD with the Cummins. First time owner of a diesel engine. The next day I'm driving down the freeway and the slip light comes on and stays on. My wife has an Infinity and I've seen the light come on in her car when I mash the gas on a wet road but it blinks and turns off immediately. So when I see the light come on and stay on I knew it was not good. I pull off the freeway and and as I'm coming to a stop at the light I feel my truck lunge forward as if someone rear ended me. Light turns green I accelerate and the trans is shifting hard through 1-3 gears. I pull over and turn the truck off and the light does not come back on. It re set its self. I get back on the freeway and the light comes back on but the truck is driving good at highway speeds. Only acts up when the slip light is on coming to a stop and taking off with the hard shifts. I'm not getting on it or anything to make the slip light come on. I do notice when the light is on that the power is limited when I go to pass on the freeway. I took the truck to the Nissan dealer being it only has 18K miles. The service adviser calls me back immediately and says that my truck is not covered under warranty due to the truck being tuned and deleted and the leveling kit. I knew the truck was obviously lifted but tuned and deleted I had no idea. (Again I'm a first time diesel truck owner) I go to pick up my truck and he shows me where the EZ Lynk turner was connected and the SOFT switch that switched between tunes was. The EZ LYNK is gone. I'm guessing the previous owner took it before he traded in the truck. The dealer I bought the truck from is a small dealer here in Houston. I told them the problems I'm having with the truck and they tell me to take it to the Nissan Dealer. Well Nissan isn't covering it due to it being tuned. So the manager tells me to take the truck to his service when the light comes and to diagnose the problem. I get the light to come and so I take it over to their service department. The tech puts the scanner on the truck and codes P0106 (MAP Sensor) comes on along with P2637 (Torque Management Feedback) He tells me the MAP sensor is whats triggering the code P2637. So he replaces the MAP and he calls me that my truck is ready. I put 100 miles on it and BAM! The freaking slip light comes back on and is still shifting hard when taking off from a stop and when I make a complete stop it lunges forward. Again, these problems only happen when the slip light is STAYING ON. Between the wheel speed sensors, ABS system, and TCM I feel like this is going to be a long process to diagnose the issue. I've only seen 1 other issue similar to this one on another forum but with no solution or input on the issue. Anything would be greatly appreciated to help me narrow down the problem. Truck is leveled on 33" after market 20'' rims. Tuned and deleted (with a missing tuner module ) fml...........

I’m having this same issue now and have already changed my MAP sensor. What was the outcome? I’m also tuned & deleted with an aftermarket cold air intake
 

·
Registered User
Joined
·
1 Posts
I bought my Titan XD 2016 not long ago, and I'm having the same exact issue your having. I was wondering if you found a solution.
 

·
Registered User
Joined
·
616 Posts
Get your own scanner. You will probably find there is also a U0101 code that they didn't tell you about which is really the problem.
 

·
Registered User
Joined
·
25 Posts
This same problem came up on mine this weekend. It’s throwing these codes, one of which is the map sensor. If anyone has any insight I would appreciate it. I’m currently on vacation and nowhere near a Nissan dealer to get it fixed
7DF789F6-8F36-4A7C-BF24-17F8D2D1C344.png
 

·
Registered User
Joined
·
25 Posts
Once I got out of the mountains and back closer to home, I did a reinstall into the ecm and it seems to have fixed the problem. Nearest I can tell, the mountain air was to thin and I wasn’t getting enough O2 to the motor.
 
1 - 13 of 13 Posts
Top