Nissan Titan XD Forum banner

1 - 16 of 16 Posts

·
Registered User
Joined
·
60 Posts
Discussion Starter #1
This might be a stupid question but I have a 2016 Titan XD SL model. It has heated seats but you can only choose between low and high. I've tried to use them to see how warm they get but on low or high I don't feel anything.... my question is am I missing something to get them to work? Like turn on the heater or defroster or something? Or is the heated seats just not that warm to begin with? Thanks
 

·
Registered User
Joined
·
614 Posts
Mine take a bit to warm up but not so hot as to burn you. Just enough heat that on a 50-60 degree morning I dont use the heater.
 
  • Like
Reactions: surveyor8030

·
Premium Member
Joined
·
363 Posts
I can definitely feel them on both low and high. Was running mine on high a few weeks back to help with a back strain on high. This was with the AC on so the elements are independent from the heating system.
 

·
Registered User
Joined
·
1,608 Posts
If it is just a heated seat and not cooled it should be electric, so when its on it should get hot. I would say if your not feeling anything they are not working. What about the passengers side?
 

·
Registered User
Joined
·
60 Posts
Discussion Starter #5
If it is just a heated seat and not cooled it should be electric, so when its on it should get hot. I would say if your not feeling anything they are not working. What about the passengers side?
Passenger side too. I don't feel anything. I feel it before I turn it on and then I turn it on and run it for about 10min and feel it again but it feels the same as when it was cold
 

·
Registered User
Joined
·
194 Posts
If it is just a heated seat and not cooled it should be electric, so when its on it should get hot. I would say if your not feeling anything they are not working. What about the passengers side?
Passenger side too. I don't feel anything. I feel it before I turn it on and then I turn it on and run it for about 10min and feel it again but it feels the same as when it was cold
If both sides are not working first thing I do is check the fuse. Bet it's not fully seated. Otherwise next step is pull up on the plastic panel that houses the controls. It just snaps in and out and make sure the plugs to each switch are fully seated. If that still doesn't work check plugs under seat. If none of that works then it's a parts issue.
 

·
Registered User
Joined
·
60 Posts
Discussion Starter #7
If it is just a heated seat and not cooled it should be electric, so when its on it should get hot. I would say if your not feeling anything they are not working. What about the passengers side?
Passenger side too. I don't feel anything. I feel it before I turn it on and then I turn it on and run it for about 10min and feel it again but it feels the same as when it was cold
If both sides are not working first thing I do is check the fuse. Bet it's not fully seated. Otherwise next step is pull up on the plastic panel that houses the controls. It just snaps in and out and make sure the plugs to each switch are fully seated. If that still doesn't work check plugs under seat. If none of that works then it's a parts issue.
Thanks. Will check the connections later today
 

·
Registered User
Joined
·
155 Posts
Check this out.

https://www.facebook.com/groups/541008459415287/ July 8th post with almost 50 replies by owners.

Mine you also can not tell they are on. Dealer says working as designed, warmers, not heated, horse ****. Says on your window sticker, heated seats.
From most of the replies, seems like the heated and cooled work the best. And the other owners, its hit and miss. (but thats normal from what nissan says.....)

There are also forums on FB, search Nissan Titan XD on FB
 

·
Registered User
Joined
·
1 Posts
Today 08:26 AM - permalink
beach driver
I can't be the only one that can't find how the seat warmers in my 2016 Titan Platinum Reserve work. Each front seat has a rotary knob with three positions left and three positions right. My driver seat never gets warm, the driver backrest does. The dealer says it is working fine but they are always closed by the time I pick it up so no one can show me. There is no color code no writing, just three leds noting position left and right. I have been on line, through the manual...nothing, what am I missing?
 

·
Registered User
Joined
·
3 Posts
So I have a 5/16 build PR and neither front seats warm or cool. The dealership has noted this and gave me a NNA case number several months ago. All "hardware" working normally so it must be a "software" (foam) issue. Are other dealerships ordering replacement foam for customers or waiting for NNA fix?
 

·
Registered User
Joined
·
624 Posts
Definitely.
 

·
Registered User
Joined
·
616 Posts
The heated seats on LOW should be warm enough to notice after about 5 minutes. On HIGH they will be uncomfortably so after about 10 minutes.

But, you have to be sitting in them for the heating elements to be on. The seats do not heat if there is nothing in them.
 

·
Registered User
Joined
·
3 Posts
The heated seats on LOW should be warm enough to notice after about 5 minutes. On HIGH they will be uncomfortably so after about 10 minutes.

But, you have to be sitting in them for the heating elements to be on. The seats do not heat if there is nothing in them.
Then I can surely say the heat dose not work in my front seats. I have not tried them in a wile but I am going to try again on the way today. Thanks!
 
1 - 16 of 16 Posts
Top