Nissan Titan XD Forum banner

1 - 18 of 18 Posts

·
Registered User
Joined
·
11 Posts
Discussion Starter · #1 · (Edited)
I got a 2016 XD with 22,600 miles on it. the code popped P00AF took it to the dealership service manager said the was low boost but would be good to drive, and to bring it up Monday for his diesel mechanic to work on it. I should have known better but it went into limp mode. Towed it to the dealership they replaced the turbo actuator and that did not fix it. Thought maybe it was the turbo but the turbo checked good. Ordered another actuator it did not fix it. They informed me this morning that they were going to order a third actuator. Do any of you have any ideas I could give the dealership I find it hard to get two bad actuators
 

·
Registered User
2016 XD 4x4 Tuned with straight pipe.
Joined
·
759 Posts
I would check all the connections, if one of the boots are loose or half off, it would definitely cause problems. Does your turbo pressure gauge register any boost?
 

·
Registered User
Joined
·
1,485 Posts
Turbo actuator. Mine did it at about 30k. Replaced under warranty

ugh...I should read the whole post! I have no idea if that isn’t it!
 

·
Registered User
Joined
·
1,052 Posts
Like @Bmw said- check all your intercooler fittings/connections. You could have a boost leak after the turbo.

Is the truck super sluggish? How’s it performing other than the CEL?

Had an afterthought- open your air box and take a look at your air filter. I vaguely remember a member on here that had sucked an ‘el-cheapo’ brand air filter almost into the turbo and was getting poor performance and low boost.
 

·
Registered User
Joined
·
11 Posts
Discussion Starter · #6 ·
With the CEL on it ran fine till it went into limp mode. It sat over night till the tow truck came started it up and it ran fine, the CEL was still on. The air filter is a frame so not a cheep one. The dealership swears they are getting bad actuators from Nissan.
 

·
Registered User
Joined
·
11 Posts
Discussion Starter · #7 ·
wakeinvol,
it all good dealership swears it’s the actuator, they are going on actuator number 3. They can’t get the CEL and 900AF to go away. Does anyone know if you have to tune the actuator for the turbo I kinda don’t think they are doing that
 

·
Registered User
Joined
·
367 Posts
Does anyone know if you have to tune the actuator for the turbo I kinda don’t think they are doing that
Absolutely, there is a procedure using the Consult software. That is what sucks about doing our own maintenance. Replacing that actuator is easy---easy access right out on top. But like so many things, you need the Consult system to finish the job! (uugh)

45665
 

·
Registered User
Joined
·
11 Posts
Discussion Starter · #9 ·
Update:
Third actuator still didn’t fix the problem. They have contacted the Nissan engineers to try to figure out what is going on with it
 

·
Registered User
Joined
·
1 Posts
Update:
Third actuator still didn’t fix the problem. They have contacted the Nissan engineers to try to figure out what is going on with it
My truck is having the same problems, what was the final conclusion to your turbo problem?
 

·
Registered User
Joined
·
4 Posts
Any update on your truck? Having the same problem and can't find an actuator anywhere. On backorder from Nissan. Hoping it is something else!
 

·
Registered User
Joined
·
3 Posts
Any update on your truck? Having the same problem and can't find an actuator anywhere. On backorder from Nissan. Hoping it is something else!
my truck developed the same issue about 4 weeks ago. Took to the dealer for diagnosis and repair. Turbo boost actuator cited as "probable" problem, but part on backorder. told me it was safe to drive, but after experiencing "limp" mode while in heavy traffic, it's far from safe.
 

·
Registered User
Joined
·
150 Posts
Taking my truck in to replace the actuator today, now that they were able to get one after two weeks. I hope this fixes the problem, and it won't ever come back.
 

·
Registered User
Joined
·
59 Posts
Taking my truck in to replace the actuator today, now that they were able to get one after two weeks. I hope this fixes the problem, and it won't ever come back.
Sure hope they solve the problem. Mine's been sitting at the dealer for 2 weeks now waiting on word of an available turbo. Its a good thing I'm not in a hurry to go anywhere this year. To make things worse, i don't trust the truck to go back up north again.
 

·
Registered User
Joined
·
150 Posts
The dealer replaced the actuator yesterday. No more CEL, and the transmission shifting now seems to be more crisp.
 

·
Registered User
Joined
·
1,485 Posts
That sucks. The waiting on parts is what got to me…when my actuator went it was available. The turbo was intermittent and wasn’t an instant necessity but I still wanted it fixed. Had to wait for it to come in and finally got frustrated and just traded! Problem solved.

I do miss my XD though. If I hadn’t been worried about other issues I would have never got rid of it.
 

·
Registered User
Joined
·
3 Posts
Taking my truck in to replace the actuator today, now that they were able to get one after two weeks. I hope this fixes the problem, and it won't ever come back.
That's good news! Maybe the supply chain is easing up a bit. Left my truck at the dealership yesterday as it was not safe to drive. It would go from normal "drive" to "limp" out of no where. The engine even died a couple of times while moving. Transmission also started shifting really hard as well! Dealer has no idea when part will be available! Nissan/Cummins not making any points with me.
 

·
Registered User
Joined
·
3 Posts
If you have been told that Titan XD engine parts are on back-order, you might want to register a complaint with Nissan Consumer Affairs. Contact number is 800/647-7261, Option 7
 
1 - 18 of 18 Posts
Top