Nissan Titan XD Forum banner
1 - 18 of 18 Posts

·
Registered User
Joined
·
53 Posts
Discussion Starter · #1 ·
Just wondering if anybody knows the difference between Proven Diesels SOTF v2.1 tune vs the SOTF V2.0_10BAR MAP?

I'm having trouble getting my SOTF switch to work. It only stays in the 0hp setting. I know for a fact I have everything connected right that I can see, wire colors are correct, no damage on wires, it's connected at the right location. Maybe somebody has had a similar experience or somebody know something I'm overlooking. I have only run the V2.1 tune since I'm assuming it is the newest version.
 

·
Registered User
Joined
·
53 Posts
Discussion Starter · #3 ·
The butt Dyno tells you instantly. There is no power difference at all between all five positions. The tune loaded great with no warnings, and the truck drives great, but the power feels almost identical to stock. I loaded the single 90 horsepower tune, and it was night and day difference.
 

·
Registered User
Joined
·
53 Posts
Discussion Starter · #5 ·
I could be somewhat content with running a single tune, but I occasionally pull my 23 ft travel trailer and would like to be able to drop it to the zero or 30 HP tune. It's not a heavy trailer at all, but we constantly have to fight 30 to 40 mph winds this time of year on the Texas coast and I don't want to push it and overheat the exhaust and tear something up.
 

·
Registered User
Joined
·
53 Posts
Discussion Starter · #10 ·
you must have pinned the connector incorrectly or the wires aren’t seated properly.

double check that connector that requires assembly during install.
Thanks so much for the help.

I double checked it already, I'll go back and triple check again. I have to be overlooking something really obvious. The colors all match up correctly, the pins pushed through correctly, none of them are bent or deflected. I might end up having to order a new switch or solder the connections instead of using the connector. I won't be able to look at it again until Monday afternoon, I'll update after that.
 

·
Registered User
Joined
·
765 Posts
Once I had to take out the SOTF knob and lost the flange causing the contacts weren't made during the switching of power level. Check on the knob itself to see if you have good connection among 5 positions.
 
  • Like
Reactions: TXSHANE

·
Registered User
Joined
·
53 Posts
Discussion Starter · #13 ·
So, all connections look good. When the truck is "on" I checked voltage on the back of the switch and it reads 8.0 at each solder point when the switch is set on each position. There is no change in voltage between each setting 1-5. The only change in voltage is when you turn the truck off. I'm thinking the switch must be bad.

Asphalt Wood Road surface Motor vehicle Recreation
Asphalt Wood Road surface Motor vehicle Recreation
 

·
Registered User
Joined
·
53 Posts
Discussion Starter · #16 ·
I sent PD an email of my issue with not switching between tunes and the troubleshooting I've done and they are sending a new switch. I'll update as soon as it comes in.
 

·
Registered User
Joined
·
53 Posts
Discussion Starter · #18 ·
Got the new SOTF switch today, installed and working! Had to have a been a bad switch. You can see the levels change on the barometric pressure PID tile on the EZLYNK this time, so it's working for a fact now. Thanks for all the help guys!!
 
1 - 18 of 18 Posts
Top